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f L A S H   3.0 
 
O Flash 3.0 é um programa que faz animações e é aceito nas versões do Internet Explorer 
3.0 ou superior , Netscape versão 4.5 ou superior , sendo que com Windows 98 não precisa 
instalar plugin, pois ele já vem embutido. Nas versões do Netscape anterior a versão 4.5 é 
necessário a instalação de plugin para que rode os arquivos em flash. 
 
 
1 - FERRAMENTAS DO FLASH 
 
• Canvas ( Área de trabalho ) –  é o corpo da tela onde são feitas as animações em Flash 
• Menu  do Flash 
• Timeline ( Linha do tempo )  - View > Timeline 
• Rullers ( Réguas na horizontal e vertical ) – View > Rullers 
• Grid ( Grades que auxiliam a disposição da animação na área de trabalho  ) – View > 

Grid 
• Barra de ferramentas –  São os ícones para acesso as ferramentas do Flash  
• Caixa de ferramentas  
• Auxiliares das ferramentas - Para cada ferramenta selecionada na caixa de 

ferramentas há alguns auxiliares que auxiliam a execução da ferramenta 
• Layers ( Camadas )  
• Scenes ( Cenas )  - View > Tabs ( cria uma primeira pasta de Scene = Cena ) 
 
2 - CONCEITOS IMPORTANTES 
 
O Flash possui uma linha do tempo , que é a janela com várias colunas e algumas linhas, 
que fica acima da área de trabalho. As linhas representam os layers e as colunas os frames.  
 
Frames representam os quadros da animação , cada quadro representa uma única posição 
da cena. Uma seqüência de quadros, a uma determinada velocidade cria o efeito de uma 
animação, uma animação é uma seqüência de quadros (frames). 
 
Layers são camadas de uma cena e que são representados na linha do tempo pelas “ bolas “ 
( bola branca, bola azul , e sem bola ) ; cada layer funciona como uma folha transparente 
sobre a cena e que desenhamos a animação . Layer 1 está acima dos demais  layers e assim 
sucessivamente.... 
 
Em cada frame pode conter : Action ( Ação )  , Sound ( Som ) e Tweening 
 
Para visualizar os Frames :  View > Show Frames  ou à direita da linha do tempo > Modify 
Frame View 
 



Para acessar o menu de Layers : Clique no botão Modify Layer  à direita do nome da layer 
na Timeline  
 
Para acessar o menu de Frames : Clique em qualquer frame de qualquer layer na Timeline. 
 
Modify Layer ( botão ao lado direito do layer ) : 
 
1. Clique com o botão direito do mouse : 
2. Current ( lápis ) – layer corrente que está sendo feito 
3. Normal ( mão branca ) – layer que já foi feito 
4. Locked ( cadeado ) – para trancar layer já feito de modo que ele não possa ser alterado 

acidentalmente 
5. Hidden ( X ) – para esconder um layer 
6. Show All – para exibir todos os layers 
7. Locked Others – para trancar os outros layers 
8. Hidden Others – para esconder os outros layers 
 
 
3 - FERRAMENTAS DO MENU 
 
File = Arquivo  para criar, abrir e salvar animações em Flash 

• File > Import ou  Ctrl + R para importar imagens de outros programas e sons 
• File > Export Movie ou Crtl + Alt + Shift + S para exportar animação 
• File > Export Image para exportar imagem 

 
Edit = Editar  objetos ou cenas em uma animação.  

• Edit > Copy ou Crtl + Alt + C para copiar animação 
• Edit > Paste ou Crtl + Alt + V para colar animação 

 
View = Visualizar  

• View > Goto determina a cena  que será editada 
• View > Outlines para visualizar os contornos 
• View > Fast  ( desativa o Anti-aliases e exibe todas as cores e linhas do desenho 

; é a melhor maneira para trabalhar ) 
• View > Antialias  
• View > Antialias Text  
• View > Timeline para visualizar a linha do tempo 
• View > Work Area para visualizar a área de trabalho 
• View > Rulers para visualizar as réguas 
• View > Tabs para visualizar a pasta das Cenas 
• View > Grid para visualizar a grade 
• View > Snap para visualizar a ferramenta imã 

 
Insert= Inserir para inserir exemplos da  biblioteca (library), camadas (layers) na cena 
corrente 



• Insert > Create Symbol ou F8 para criar símbolos 
• Insert > Layer para criar camadas 
• Insert > Motion Guide para criar animação “ Add Motion Guide”  
• Insert > Frame  ou F5 para criar quadros da animação 
• Insert > Delete Frame ou Shift + F5 para deletar o quadro 
• Insert > KeyFrame ou F6 para criar chave de quadro “ bola azul “ 
• Insert > Blank KeyFrame ou F7 para criar chave de quadro “ bola em branco “ 
• Insert > Clean Keyframe ou Shift + F6 para criar chave “ sem nada” no quadro 
• Insert > Scene para inserir Cena 
• Insert > Show Shape Hints para exibir os hints quando estiver usando o Efeito 

Shape 
 
Modify = Modificar para modificar os objetos de uma animação .  

• Modify > Instance para modificar a instância de um símbolo 
• Modify > Scene para modificar Cena 
• Modify > Movie  ou Crtl M para modificar Animação 
• Modify > Kerning ( para modificar o espaço entre as letras ) 
• Modifty > Transform >Scale and Rotate ou Crtl + Alt + S para aumentar o 

objeto ou rotacioná-lo 
• Modifty > Transform > Rotate Left para rotacionar para esquerda 
• Modifty > Transform > Rotate Right para rotacionar para direita 
• Modify > Transform  > Rotate Vertical para rotacionar para Vertical 
• Modify > Transform >  Rotate Horizontal para rotacionar para Horizontal 
• Modifty > TraceBitmap  usar este recurso com arquivos provenientes de outros 

programas  
 
 
Control = Controle  para controlar  a animação . 

• Control > Test Movie ou Crtl + Enter para testar Animação 
• Control > Teste Scene ou Crtl + Alt + Enter para testar Cena 
• Control > Loop Black para voltar o loop 
• Control > Play All Scenes para tara tocar todas as cenas 
• Control > Enable Actions ou Crtl + Alt + A para ativar as Ações 
• Control > Enable Button ou Crtl + Alt + B para ativar os Botões 
• Control > Mute Sounds ou Crtl + Alt + M para desativar sons 

 
Libraries ( Biblioteca do Flash ) 

• Buttons ( Botões ) 
• Graphics ( Gráficos ) 
• Movie Clips 
• Sounds ( Sons ) 

 
Window = Janela  

• Windows > Toolbars para controlar a exibição das barras de ferramentas 
• Windows > Color para acionar a exibição da ferramenta Cor > Gradiente 



• Windows > Inspector para exibir as coordenadas numéricas de um objeto 
• Windows > Output ****** 
• Windows > Library ou Crtl + L para exibir a biblioteca criada por você 

 
Help = Ajuda 

• Help > Flash Help Topics ou F1 ( Tópicos de Ajuda sobre o Flash ) 
• Help > Guide Tour ( Tour sobre o uso do Flash ) 
• Help > Lessons ( Lições para você exercitar o Flash ) 
• Help > Samples ( Exemplos de Flash ) 

 
4 - CAIXA DE FERRAMENTAS 
 

Arrow = Setas Text Tool = Texto 
Pencil = Lápis Ink Bottle = Nankin 
Brush = Pincel Paint Bucket = Balde de Tintas 
Eraser = Borracha Dropper = Conta Gotas 
Zoom = Lente de Aumento Lasso = Laço 

 
 
5 - OUTRAS FERRAMENTAS DO FLASH 
 

Layers = Camadas 
Layer Guide = Guia da Camada 
Timeline - Tempo decorrido 
Velocidade 
Frame Atual 
 
1. Nº do frame em qual a linha do tempo está posicionada 
2. Velocidade da animação 
3. Tempo decorrido da sua animação até o exato momento 
 
* Caso dê dois clique sobre a velocidade abrirá automaticamente o Modifity > Movie 
 

 
Onion Skin = Casca de Cebola 
Onion Skin Outlines = Contorno da Casca de Cebola 
Edit Multiple Frames = Editar Múltiplos Frames 
Modify Onion Markers = Marcadores da Casca de Cebola 

 
6 - BIBLIOTECA ( LIBRARY ) 
 
A library é a biblioteca do itens associados a animação 
 
• Para abrir a Library do Flash > Libraries > Buttons , Graphics , Movie Clips e 

Sounds  e escolha a opção desejada 



• Para abrir sua Library Windows > Library 
 
 

Símbolos Bitmap Som Play Menu da 
Biblioteca 

Status do Símbolo 
Previsão do Símbolo 
Lista dos Símbolos 

 
 
7 - FERRAMENTA SETA 
 
1. Clique na ferramenta Arrow ( Seta ) 
2. Abrirá na parte de baixo as ferramentas auxiliares da Seta : Imã, Suave, Aresta, 

Rotação, e Escala. 
3. Snap = Imã ( Snap pode ser ativado ou desativado  ) 
4. Ferramentas Auxiliares do Arrow : 

Smooth - Suavizar o contorno 
Straighten - Angular o contorno ou as arestas 
Rotate - Rotacionar , alterar o tamanho e alinhar objeto 
Scale - Ajuste do Zoom 

 
Observação : O imã controla a quebra e a conexão de linhas durante a modelagem. Clique 
no Imã para ativá-lo ou desativá-lo, e então arraste sua extremidade para a posição 
horizontal. 
 
8 - FERRAMENTA : TEXTO 
 

1. Clique na ferramenta Texto 
2. Abrirá na parte de baixo as ferramentas auxiliares do Texto : Fonte, Tamanho da Fonte, 

Cor do Texto , Alinhamento, Estilo ( Negrito e Itálico ) e o de Parágrafo. 
 
9 - FERRAMENTAS LÁPIS E NANKIN 
 
1. Clique na Ferramenta Pencil ( Lápis ) 
2. Abrirá na parte de baixo as ferramentas auxiliares do Lápis 
3. Pencil Mode = Formas de Lápis 
4. Line Color = Linha de Cor 
5. Line Tickness = Espessura da Linha 
6. Line Style = Estilo da Linha 
 
Se clicar em Pencil Mode = Formatas de Lápis abrirá as ferramentas auxiliares : 
• Straighten = para desenhar  linha reta  
• Smooth = para desenhar à mão livre 
• Ink = para desenhar com Nankin 



• Oval = para desenhar círculo ou oval 
• Rectangule = para desenhar quadrado ou retângulo 
• Line = para desenhar  linha 
• Escolha retângulo como formato do lápis. Desenhe um quadrado.  
 
1. Clique na Ferramenta Nankin 
2. Abrirá na parte de baixo as ferramentas auxiliares do Nankin 
3. Pencil Mode = Formas de Lápis 
4. Line Color = Linha de Cor 
5. Line Tickness = Espessura da Linha 
6. Line Style = Estilo da Linha 
 
10 - FERRAMENTAS PINCEL E BALDE 
 
 

Brush = Pincel 
Brush Mode = Estilo do Pincel Pressão 

Fill Color = Cor do Pincel 
Brush Size = Tamanho do Pincel 
Brush Shape = Formato do Pincel 
Lock Fill = Cadeado do Degradê 

Paint Bucket = Balde 
Fill Color = Cor de Preenchimento 

Gap Size = Tamanho do vão 
Lock Fill = Cadeado de Preenchimento Transform Fill = Transformação do Preenchimento

 
Clique na ferramenta do Balde 
Clique na ferramenta auxiliar Gap Size = Tamanho do Vão  
 
Clique na ferramenta auxiliar Transform Fill : Gradiente radial e linear 
 
Para editar um degrade radial: 
1. Selecione o Balde de Tinta e ative a Edição de Preenchimento. 
2. Selecione a esfera. Quatro alças aparecerão no círculo de marcação da esfera: 
 
• Alça Central 
• Alça de Distorção 
• Alça de Redimensionamento 
• Alça de Rotação 
 
11 - FERRAMENTAS : BORRACHA E CONTA GOTAS 
 
1. Clique na Ferramenta  Eraser ( Borracha ) 
2. Abrirá na parte de baixo as ferramentas auxiliares da Borracha : 



3. Eraser Mode = Modo de Apagamento  
4. Eraser Shape = Forma de Borracha  
5. Faucet = Torneira ( limpa áreas fechadas de preenchimento ) 
 
1. Clique na Ferramenta  Dropper ( Conta Gotas ) 
2. Abrirá na parte de baixo as ferramentas auxiliares de Conta Gotas 
 
 
12 - FERRAMENTAS : ZOOM , LAÇO  E IMÃ 
 
Clique na ferramenta Zoom 
 
1. Clique na Ferramenta Lasso ( Laço ) 
2. Abrirá na parte de baixo as ferramentas auxiliares do Laço : 
3. Magic Wand = Varinha Mágica 
4. Magic Wand Properties = Propriedades da Varinha Mágica 
5. Snap = Imã ( quando ativado atrai dois objetos ) 
 
 
13 - ATALHOS NO FLASH 
 
A > Arrow (Ferramenta de Seleção) 
T > Text (Cursor texto) 
P > Pen Tool (Lápis) 
M > Magnifier (Zoom) 
M + Alt > Zoom  ( - ) 
Barra de espaço > Carrega a janela. Efeito semelhante ao mover as barras de rolagem da 
área de trabalho 
Mover elemento + CRTL > Duplica o elemento (shape, group, botão, symbol, movie, 
bitmap...) 
F1 > Help  
I  > Ink (contorno dos shapes) 
B > Brush (Pincel ) 
U > Paint (Balde de preenchimento) 
E > Eraser (Borracha) 
D > Dropper (Captura atributos de preenchimento) 
L > Lasso para seleção 
 
14 – EFEITO TWEENING MOTION 
 
 
O efeito Tweening : Motion é a animação em linha reta de dois Frames ( Quadros ) 
 
• Bola Branca = Blank key frame ; não há objeto nenhum nesta posição 
 



• Bola Azul = key frame ; um layer com conteúdo que pode representar uma nova 
posição na seqüência. Key frames são frames chaves que representam alguma alteração 
na animação. 

 
• Bola Azul acrescida de Seta Vermelha = Key Frame com Tweening 
 
• Bola Azul acrescida de Riscos em Preto =  Key  Frame com Som 
 

WCOMO FAZER TWEENING MOTION 
 
1. Veja exemplo anexo : motion_simples.fla 
2. Usando a ferramenta auxiliar do Pencil , desenhe uma bola 
3. Usando a ferreamente Balde pinte a bola 
4. Observe que abaixo da linha do tempo foi exibido uma Bola Azul ( Key Frame ) 
5. Selecione toda a bola > F8 para criar um símbolo : name = bola e behavior = graphic 
6. Clique no mouse com o botão direito na mesma linha deste layer na linha do tempo = 

30 
7. Insert > KeyFrame ou F6 criando outra Bola Azul ( KeyFrame ) 
8. Mova a bola do keyframe da linha 30 para direita 
9. Selecione a linha 1 até 29 
10. Com o botão direito do mouse : Selecione Properties ( Propriedades ) 
11. Escolha Tweening > Motion 
12. Observe que ficou uma linha vermelha entre os dois keyframes 
13. Crtl + Enter e teste sua animação 
 
PROPRIEDADES DO TWEENING MOTION : 
 
Rotate ( Rotação ) : Automatic ( Automático ) ; Clockwise ( Sentido Horário ) ; 
Counterclockwise ( Sentido anti-horário ) 
Easing  ( Aceleração ) 
 

WESTRELA COM EFEITO 
 
1. Veja exemplo anexo : estrela.fla  
2. Windows > Library 
3. Clique na seta preta da Library > Create Symbol 
4. Name : estrela e behavior : graphic 
5. Desenhe um retângulo 
6. Pinte de um cor 
7. Delete as bordas 
8. Com a ferramenta Pencil > Line , faça um triângulo 
9. Delete as partes indesejáveis e as bordas 
10. Selecione o triângulo 
11. Crtl + D para fazer uma cópia do triângulo 
12. Arraste a cópia para fora 



13. Selecione o segundo triângulo > Modify > Transform > Scale and Rotate 
14. Rotate = 60 
15. Faça a mesma coisa com a 3ª , 4ª , 5ª e 6ª cópias respectivamente , mudando somente o 

Rotate para 120 , 180 , 240 , 300 
16. Movimente os triângulos para formar uma estrela 
17. Selecione tudo > F8 > criando outro símbolo  
18. Name : estrela1 behavior : movie clip  
19. Insira outro keyframe na linha 50 
20. Selecione a linha 1 até 49 > Tweening > Motion > Clockwise = 999 
21. Clique na seta azul para fechar a edição do símbolo 
22. Windows > Libray 
23. Selecione estrela1 ( movie clip ) e arraste para área de trabalho 
24. Insira frame na linha do tempo = 50 
25. Crtl + Enter e teste sua animação 
 
COMO ALINHAR UM TEXTO 
 
1. Clique na ferramenta Text e digite um texto 
2. Edit > Select All 
3. Clique na ferramenta Arrow ( Seta ) 
4. Modifity >  Align ou Crtl + K 
 
CANTOS ARRENDODADOS 
 
1. Faca um retângulo e deixe vazio dentro. 
2. Acione o SNAP ( Imã ) e desenhe um pequeno circulo partindo do interior da aresta do 

retângulo. 
3. Delete as linhas indesejáveis . 
 
COMO ADICIONAR UM KEY FRAME NO INÍCIO  
 
1. Não pode ter tweening 
2. Posicione a linha do tempo no 1º frame + F5 e vá pressionado F5 até na posição 

desejada 
3. Posicione na nova posição do frame = Insert Key Frame 
4. Volta ao primeiro frame e selecione objeto do frame 
5. Delete 
 
** Atalho para frames na linha do tempo :  

• F5 para aumentar a duração da animação 
• Shift + F5 para diminuir a duração da animação 

 
COMO EDITAR UM GRUPO 
 
1. Desenhe dois objetos e selecione-os 
2. Modify > Group 
3. Clique duas vezes fora dos objetos  para desativar a seleção 



 
Group é um recurso usado para fazer criação da sua animação ;  
Não é símbolo e nem é exportado como desenho 
 

WCOMO ROTACIONAR UM TEXTO 
 
1. Veja exemplo anexo : texto_rotac.fla 
2. Digite a palavra FLASH em verde > Arial Black > fonte = 36 
3. Selecione o texto > F8 > símbolo > name = texto1 ; behavior = graphic 
4. Insert key frame na linha do tempo = 40 
5. Selecione a linha do tempo = 1 
6. Selecione o texto > Modify >  Transform > Flip Horizontal 
7. Selecione a linha 1 até a 40 > Properties > Tweening > Motion 
8. Insira um layer abaixo 
9. Insira um keyframe deste novo layer na linha 41 
10. Digite palavra FLASH em vermelho > Arial Black > fonte = 36 
11. Selecione o novo texto > F8 > símbolo > name = texto2 ; behavior = graphic 
12. Selecione a linha do tempo = 80 deste novo layer 
13. Selecione a linha do tempo = 41 deste novo layer 
14. Selecione o texto > Modify > Transform > Scale and Rotate 
15. Scale = 500 e Rotate = 0 
16. Usando a seta do teclado mova o texto para parte de baixo até que desapareça 

completamente 
17. Selecione a linha do tempo 41 até 79 > Properties > Tweening > Motion 
18. Clique na linha do tempo = 80 > Properties > Action > + > Stop 
19. Crtl + Enter e teste sua animação 
 
15 - SÍMBOLOS 
 
COMO CRIAR SÍMBOLOS 
 
1. Desenhe um objeto 
2. Edit > Select All ou Selecione-o com a ferramenta Arrow ( Seta ) 
3. Insert > Create symboll ou F8 
 
PARÂMETROS DE SÍMBOLOS 
 
1. Selecione o Símbolo > Properties 
2. Clique pasta Definition ( Definição ) 
3. No item Behavior ( tipos de símbolos ) 

Graphic – Símbolo Gráfico para objetos 
Button – Símbolo Botão para criar botões 
Movie Clip  - Símbolo de um Clip de uma animação 

 
INSTÂNCIA DE UM SÍMBOLO GRÁFICO 
 



1. Na pasta Definition ( Definição ) 
2. No item Behavior = Graphic 
3. No item Play Mode Options ( Opções para Rodar o símbolo ) 

Loop – rodar animação 
Play once – rodar animação uma vez 
Single Frame – frame simples 

4. Clique na pasta Color Effects (  Efeitos para colorir símbolo ) 
 
INSTÂNCIA DE UM SÍMBOLO BOTÃO 
 
1. Na pasta Definition ( Definição ) 
2. No item Behavior = Button 
3. No item Tracking Options ( Opções do Cursor ) 

Track as Menu ( Cursor como Menu ) 
Track as Menu Item ( Cursor como Item do Menu ) 

4. Clique na pasta Color Effects (  Efeitos para colorir símbolo ) 
5. Clique na pasta Actions ( Ações do botão ) 
 
INSTÂNCIA DE UM SÍMBOLO MOVIE CLIP 
 
1. Na pasta Definition ( Definição ) 
2. No item Behavior = Movie Clip 
3. No item InstanceOptions ( Opções da Instância ) 

Instance Name ( Nome da Instância ) 
4. Clique na pasta Color Effects (  Efeitos para colorir símbolo ) 
 
 
16 – EFEITO TWEENING MOTION GUIDE 
 
Motion Guide é a forma avançada do Tweening Motion , ou seja , a animação em dois 
Frames ( Quadros ) com movimentação feitas à mão 
 

WMOTION GUIDE SIMPLES 
 
1. Veja exemplo anexo : guide.fla 
2. Desenhe uma bola 
3. Selecione-a 
4. Insert > Creat Symbol ou F8 
5. Name = bola e bahavior = graphic 
6. Insira um keyframe na linha 40 
7. Com a linha 40 selecionada, mova a bola para a direita 
8. Selecione a linha do tempo 1 até 39 
9. Com o botão direito do mouse > Properties > Tweening > Motion 
10. Clique  no ícone Modify Layer  ( ao lado direito do layer 1) 
11. Selecione Add Motion Guide ( Adicionar Guia para Animação ) 
12. Abrirá um layer abaixo Tweening = Motion = ( x ) Orient to path direction  



13. Clique no Botão = Edit Multiple Frames ( acima do layer 1 ) 
14. Na linha do tempo aparecerá duas setas cinzas 
15. Arraste uma para linha do tempo 1 e a outra para linha do tempo 40 
16. Clique na ferramenta Pencil > ferramenta auxiliar Smooth 
17. Desenhe o caminho por onde você deseja  que passe animação; sendo que começa no 

eixo inicial e termina no eixo final de cada bola 
18. Crtl + Enter e teste sua animação 
 
Observações : 
 
Os ajustes de Easing dentro do Motion : 

• In = começa mais lento e acelera no final 
• Out = começa rápido e desacelera no final 

 
O path que você desenhar  tem que ter as seguintes especificações : 

• Não ser um polígono fechado 
• Sempre juntar o eixo inicial ao eixo final 

Para melhorar a suavidade do movimento = aumentar  = marca do tempo = F1 
 

WTEXTO COM ADD MOTION GUIDE 
 
1. Veja exemplo anexo : guide1.fla 
2. Ao lado da Scene1 > clique em 12.0 fps e coloque background = preto 
3. Renomeie o layer de “A” 
4. Digitar a palavra AMOR em azul e com fonte Arial Black e tamanho 48 
5. Selecione o texto > Modify > BreakApart 
6. Com o texto se transformou em imagem 
7. Selecione a letra A > ferramenta balde e pinte de vermelho 
8. Deselecione a letra A 
9. Selecione a letra M > ferramenta balde e pinte de roxo 
10. Deselecione a letra M 
11. Selecione a letra O > ferramenta balde e pinte de verde 
12. Deselecione a letra O 
13. Selecione a letra R > ferramenta balde e pinte de branco 
14. Deselecione a letra R 

 
15. Selecione a letra A > F8 > name = A ; behavior = graphic 
16. Selecione a letra M > F8 > name = M ; behavior = graphic 
17. Selecione a letra O > F8 > name = O ; behavior = graphic 
18. Selecione a letra R > F8 > name = R ; behavior = graphic 
19. Windows > Library e veja todos os símbolos criados 

 
20. Selecione a linha do tempo 1 
21. Edit > Copy Frames ou Crtl + Alt + C 
22. Insira um layer abaixo  
23. Clique na linha 1 deste layer > Edit > Past Frames  ou Crtl + Alt + V 



24. Renomeie o layer de “M “ 
 

25. Insira um layer abaixo  
26. Clique na linha 1 deste layer > Edit > Past Frames  ou Crtl + Alt + V 
27. Renomeie o layer de “O “ 

 
28. Insira um layer abaixo  
29. Clique na linha 1 deste layer > Edit > Past Frames  ou Crtl + Alt + V 
30. Renomeie o layer de “R” 

 
31. Clique no ícone Modify Layer > Current  do layer “A“ que aparecerá o lápis 
32. Clique no botão lápis novamente > Hidden Others para esconder os outros layers 
33. Delete as letras M O R 
34. Insira um keyframe na linha 40 
35. Selecione a linha 1 e arraste a letra A para o lado de cima à direita 

 
36. Clique no ícone Modify Layer > Current  do layer “M“ que aparecerá o lápis 
37. Clique no botão lápis novamente > Hidden Others para esconder os outros layers 
38. Delete as letras A O R 
39. Insira um keyframe na linha 40 
40. Selecione a linha 1 e arraste a letra M para o lado de cima à esquerda 

 
41. Clique no ícone Modify Layer > Current  do layer “O“ que aparecerá o lápis 
42. Clique no botão lápis novamente > Hidden Others para esconder os outros layers 
43. Delete as letras AM R 
44. Insira um keyframe na linha 40 
45. Selecione a linha 1 e arraste a letra O para o lado de baixo à direita 

 
46. Clique no ícone Modify Layer > Current  do layer “R“ que aparecerá o lápis 
47. Clique no botão lápis novamente > Hidden Others para esconder os outros layers 
48. Delete as letras AM O 
49. Insira um keyframe na linha 40 
50. Selecione a linha 1 e arraste a letra R para o lado de baixo à esquerda 
 
51. Volte ao layer A 
52. Selecione a linha 1 até 39 > Properties > Tweening > Motion 
53. Repita o mesmo procedimento com os outros layers dando Tweening > Motion 

 
54. Clique no ícone Modify Layer > Current  do layer A que parecerá o lápis  
55. Clique no novamente ícone Modify Layer > Hidden Others  do layer A para esconder 

os outros layers 
56. Clique no ícone Modify Layer >  Add Motion Guide 
57. Clique no ícone Edit Multiple Frame ( ícone vermelho ) 
58. Aparecerá a seta cinza na linha do tempo 
59. Arraste uma seta para linha do tempo 1 e a outra para linha 40 
60. Clique na ferramenta Pencil > ferramenta Smooth 



61. Desenhe o caminho por onde irá passar a letra A ; lembrando-se que deve iniciar no 
eixo do símbolo e terminar no eixo do outro frame 

62. Crtl + enter e teste a movimentação da letra  A 
63. Crtl + F4 para voltar a área de trabalho 
64. Repita o mesmo procedimento dos itens 54 à 62 para as outras letras 
65. Crtl + Enter e teste sua animação 
 
17 - BOTÕES 
 
OS BOTÕES NO FLASH TEM 4 ESTÁGIOS 
 
1. Up = como o botão aparece sem o mouse 
2. Over = como o botão aparece quando o mouse passa por cima do botão  
3. Down = como o botão aparece quando você clica no botão 
4. Hit = define a área " clicável " do botão, ou seja, a área em que ele é acionado  
 
COMO FAZER BOTÕES  
 
1. Desenhe um botão 
2. Selecione o desenho 
3. Transforme o desenho em símbolo Insert > Create Symbol ou  F8 
4. Control > Enable Button 
5. Selecione a opção "Button"  para transforma-lo em um botão 
6. Clique duas vezes sobre o desenho para editar o botão ou Ctrl+E  
7. Clique em Edit 
8. Clique na Timeline  no estágio Down para  criar um keyframe  ou F6 
9. Ctrl+E de novo para voltar a edição da animação 
10. Clique duas vezes no ícone ; clique Actions  
11.  Selecione "Get URL", e coloque a URL que você deseja que o usuário visite quando 

clicar no botão  ; caso queira fazer um link para email : mailto:abc@provedor.com.br 
 

 
COMO FAZER UM DESENHO DE BOTÃO NO FLASH 
 
1. Desenhe um retângulo 
2. Selecione os quatro cantos 
3. Ctrl D 
4. Arraste para fora do quadrado e redimensiona para menor 
5. Sobreponha sobre o maior 
6. Transform > Fill 
7. Para o retângulo maior = aumente a bola para dar efeito 
8. Para o retângulo menor = diminua a bola para dar efeito 
9. Clique em cada linha do retângulo menor e delete 
 



 
ANIMAÇÃO PARA QUADRO – BOTÃO 
 
1 ) Selecione o desenho 
2 ) Insert = Creat Symbol = F8 
3 ) Abrirá uma Caixa de Diálogo : Symbol Properties 
4 ) No item Name digite o nome do botão 
4 ) Marque ( Buttons ) 
4 ) Clique sobre imagem com o mousse pressionando o botão direito 
5 ) Selecione Edit 
6 ) Up | Over | Down | Hit 
7 ) Hit 
8 ) Insert Key Frame 
9 ) Selecionar parte desejada do frame 
10 ) Insert Key Frame 
11 ) Over 
12 ) Insert Keyframe 
13 ) Clique no Botão azul ( à direita na parte de cima ) para voltar o desenho original 
14 ) Control > Enable button  
15 ) Control > Test Movie ou Crtl + Enter 
16 ) Control > desativar Enable button 
 
Obs. O símbolo sempre tem um ( + ) no meio da imagem quando está sendo editada. 
 
AÇÕES DO BOTÃO 
 

• None - default   
• Play – Ativa a Cena Corrente  
• Stop – Para a animação  
• Next Frame – Ir para o próximo frame  
• Previous Frame – Ir para o frame previsto  
• Next Page – Ir para um frame específico na próxima Cena  
• Previous Page- Ir para um frame específico para uma Cena Prevista  
• Toggle High Quality  
• Goto – Ir de um frame especifico para uma Cena Scene  
• Get URL – Ir para uma determinada página ( URL ou Email )  
• Goto and Play – Ir de um frame específico para uma Cena Específica e rodar 

animação  
• Get URL and Goto – Exibir uma URL numa janela específica e depois ir para um 

frame determinado na Cena  
• Get URL, Goto and Play - Exibir uma URL numa janela específica e depois ir para 

um frame determinado na Cena e rodar animação 
• Stop All Sounds- parar todos os sons 

 

 



WBOTÃO – I : BOTÃO SIMPLES 
 
1. Veja exemplo anexo : botao1.fla 
2. Desenhe um botão 
3. Selecione o botão : Edit > Select All 
4. Insert>Create Symbol ou F8     
5. No item Behavior ( x ) Button 
6. Clique sobre o desenho pressionando o botão direito do mouse 
7.  Ou clique duas vezes sobre o desenho 
8. Selecione > Properties 
9. Clique em Edit 
10. Aparecerá os 4 Estágios de um botão UP , OVER , DOWN e HIT 
11. Clique sobre HIT > Insert Key Frame ou F6 
12. Clique sobre OVER > Insert Key Frame ou F6 
13. Modifity > Scale and Rotate 
14. No item Rotate digite 85 
15. Libray > Sound ( Escolha um Som ) ou File > Import ( Importe um Som ) 
16. Arraste o Som escolhido para cima do desenho do botão 
17. Clique sobre DOWN > Insert Key Frame ou F6 
18. Pinte o botão de outra cor 
19. Libray > Sound ( Escolha outro Som ) ou File > Import ( Importe outro Som ) 
20. Clique na Seta Azul para voltar ao Formato Original 
21. Crtl + Enter e teste sua animação 
 
Nas propriedades de um símbolo > Color Effect  
 
1. Brightness - mais ou menos brilho 
2. Tint – pintar o objeto 
3. Alpha – dar tonalidade na cor 
4. Special – modificar cor 
 
BOTÃO - II  : BOTÃO COM EFEITO 
 
1. Desenhe um botão 
2. Edit > Select All 
3. F8 para criar símbolo 
4. Name : botão 2 
5. Behavior : button 
6. Clique OK 
7. Clique duas vezes sobre o desenho para editar o botão 
8. Clique em Edit 
9. Clique em Hit > F6 
10. Clique em Over > F6 
11. Usando as ferramentas do Flash aumente as bordas da parte cima e de baixo 
12. Mude de Cor e insira som 
13. Clique em Down > F6 



14. Usando as ferramentas do Flash diminua a borda da parte de cima levando para baixo 
15. Mude de Cor e insira som 
16. Clique na seta azul para desativar a edição do botão 
17. Clique com o botão direito do mouse pressionado > Properties 
18. Color Effect > Alpha  em 30% 
19. Actions > + > Get URL 
20. Digite : exer1.htm 
21. Control > Enable Buttons 
22. Crtl + Enter ou Control > Test Movie 
23. Volte a Área de Trabalho e clique duas vezes sobre o botão 
24. Clique em Edit 
25. Insira novo layer 
26. Desenhe um retângulo em vermelho maior que o botão ( do lado esquerdo ) 
27. Selecione o retângulo vermelho e F8 
28. No estagio Hit > F6 
29. No estagio Over > F6 
30. No estagio Down > F6 
31. No estagio Hit selecione o quadrado e delete 
32. No estagio Over  digite um texto 
33. No estagio Down digite outro texto  
34. Clique na seta azul 
35. Crtl + Enter 
 
BOTÃO  III 
 
1. Desenhe um botão e dê o nome de botão 1 
2. Selecione o botão e F8 ; button > Name = Botão 1 
3. Dê nome ao layer = Bola 1 
4. Insira keyframe > F6 na linha do tempo = 10 
5. Insira blank keyframe na linha do tempo = 13 
6. Ponha cursor antes do último frame > F5 até a linha do tempo = 20 
7. Insert > Keyframe ; Insira novo frame e dê nome de Entrada 
8. Desenhe um retângulo  
9. Selecione o retângulo > F8 > Button > Name : Retângulo 1 
10. Dê 3 keyframe 
11. No último keygrame : Modifty > Scale and Rotate > 200% 
12. Arraste o desenho para parte de baixo ( do lado direito ) 
13. Insira blank keyframe na linha do tempo = 10 
14. Insira blank keyframe na linha do tempo = 13 
15. Ponha cursor antes do último frame > F5 até a linha do tempo = 20 
16. Clique no frame Bola 1 > Insert > Frame  
17. Dê nome ao layer = Bola 2 
18. Dê Blanck KeyFrame 
19. Dê KeyFrame na linha do tempo =2 
20. Windows > Library > Botão 1 e coloque ao lado da Bola 1 
21. Insira keyframe na linha do tempo = 11 
22. Insira blank keyframe na linha do tempo = 13 



23. Clique no frame Bola 2 > Insert > Frame  
24. Dê nome ao layer = Bola 2 
25. Dê Blanck KeyFrame 
26. Dê KeyFrame na linha do tempo =3 
27. Windows > Library > Botão 1 e coloque ao lado da Bola 2 
28. Insira keyframe na linha do tempo = 12 
29. Insira blank keyframe na linha do tempo = 13 
30. Clique no frame Bola 3 > Insert > Frame  
31. Dê o nome ao frame de Action 
32. Na linha do tempo = 1 > Blank Keyframe > Properties > Action > Stop 
33. Na linha do tempo = 4 > Blank Keyframe > Properties > Action > Stop 
34. Na linha do tempo = 10 > Blank Keyframe > Properties > Action > Play 
35. Na linha do tempo = 11 > Blank Keyframe > Properties > Action > Play 
36. Na linha do tempo = 12 > Blank Keyframe > Properties > Action > Play 
37. Na linha do tempo = 13 > Blank Keyframe > Properties > Action > Play 
38. Na linha do tempo = 20 > Blank Keyframe > Properties > Action > Go to > Label > 

flash1.htm 
39. Clique no frame Action > Insert > Frame 
40. Dê o nome de Comentários 
41. Na linha do tempo = 1 > Blank Keyframe > Properties > Label >Comment > Name : 

Input 
42. Na linha do tempo = 10 > Blank Keyframe > Properties > Label > Comment > Name : 

Output 
Na linha do tempo = 14 > Blank Keyframe 
 

WBOTÃO COM SETA SEGUE E VOLTA 
 
1. Veja exemplo anexo : botao_segue.fla 
2. Windows > Library > Create Symbol 
3. Graphic e name = modelo 
4. Desenhe um pequeno retângulo e pinte 
5. Selecione o objeto > Crtl + K para alinhar os objetos 
6. Vertical > Align > terceiro botão 
7. Horizontal > Align > terceiro botão 
8. Match Size > marque X 
9. Marque : Align to page 
10. Windows > Library > Create Symbol 
11. Button e name = botaosegue 
12. Arraste do Library > modelo para área de trabalho 
13. Digite do lado de fora do retângulo : SEGUE 
14. Selecione o objeto > Crtl + K para alinhar os objetos 
15. Vertical > Align > terceiro botão 
16. Horizontal > Align > terceiro botão 
17. Match Size > marque X 
18. Marque : Align to page 
19. Faça keyframe nos estágios : Over , Down e Hit 



20. Windows > Library > Create Symbol 
21. Button e name = botaovolta 
22. Arraste do Library > modelo para área de trabalho 
23. Digite do lado de fora do retângulo : VOLTA 
24. Selecione o objeto > Crtl + K para alinhar os objetos 
25. Vertical > Align > terceiro botão 
26. Horizontal > Align > terceiro botão 
27. Match Size > marque X 
28. Marque : Align to page 
29. Faça keyframe nos estágios : Over , Down e Hit 
30. Clique na seta azul da edição dos símbolos e volte a área de trabalho principal  
31. Digite  em Arial Black com tamanho 48 = Cena 1 
32. Faça um keyframe na linha do tempo = 40 
33. Clique sobre a linha do tempo = 40 > Properties > Action >Stop 
34. Windows > Library e arraste o botão SEGUE 
35. Clique no botão segue > Properties > Action > On MouseEvent ( x ) Press 
36. Mantendo a Action aberta clique em + Goto > Scena 2 e marque Go and Play 
37. Insert > Scene para inserir nova cena 
38. Digite  em Arial Black com tamanho 48 = Cena 2 
39. Faça um keyframe na linha do tempo = 40 
40. Clique sobre a linha do tempo = 40 > Properties > Action >Stop 
41. Windows > Library e arraste o botão VOLTA 
42. Clique no botão segue > Properties > Action > On MouseEvent ( x ) Release 
43. Mantendo a Action aberta clique em + Goto > Scena 1 e marque Go and Play 
44. Crtl + Enter e teste sua animação 
 
18 – ACTIONS - AÇÕES DE UM FRAME 
 
• Go to = Ir para 

Parâmetros do Go to : 
Frame : (  ) Frame – ir para o Frame X 
             (  ) Label - 
             (  ) Next Frame – ir para o próximo Frame 
             (  ) Previous Frame 
 Control : (  ) Go to and Play – ir para e ative animação 
 

• Play = Ativar a animação ( não tem nenhum parâmetro ) 
• Stop = Parar a animação ( não tem nenhum parâmetro ) 
• Toggle High Quality = Para ativar ou desativar o anti aliasing ( serrilhamento ); ( não 

tem nenhum parâmetro ) 
• Stop All Sounds = Desativar todos os Sons ( não tem nenhum parâmetro ) 

 
• Get Url = Ir para determinada página 

Parâmetros do Get Url : 
URL : digite a página determinada 
Windows : este parâmetro é usado quando a página está em frame :  



                  _self ( abre na própria página )  
                 _blank ( abre uma nova janela no monitor ) 
                 _parent se a pagina estiver no mesmo diretório no servidor 
                 _top ( abre sobre a página original ) 
Link para email : digite : mailto:abc@provedor.com.br”  
Usando JavaScript : 
Para abrir a página da Macromedia, digite no campo Get URL: 
javascript:window.open("http://www.macromedia.com") 
 

• FS Command = Comando que roda numa aplicação  
Parâmetro do FS Command :  Command and Arguments  
 

• Load Movie = Carrega o Movie ; é muito útil para a velocidade do download , essa 
ação faz com que o swf carregue outro swf , isto é , se a sua página tem uma animação 
depois um menu  , é melhor faze-los separados e no final da animação colocar um load 
movie  

 
• Unload Movie = caso se use o Load Movie, para não carregar o Movie 

 
• Tell Target = é um recurso que controla as ações de um movie clip no movie principal 

ou para criar botões liga e desligada em caso do uso de sons 
Parâmetro : Begin Tell Target ( Iniciar Tell Target ) : 
Target ( Alvo ) 
 

• Is Frame Loaded = O Frame está carregado 
Parâmetro : Is Frame Loaded 
                   Scene 
                   Frame : (  ) Number (  ) Label 
 

• On Mouse Event = Eventos do Mouse 
 
 
19 – COMO IMPORTAR IMAGENS DE OUTROS PROGRAMAS 
 
As extensões aceitas : bmp , gif , png , wmf, eps e dxf . O jpg é aceito, mais pelo fator de 
compressão quando no Flash se dá um Break Apart para se tornar vetorial ela perde muito a 
resolução , por isto é aconselhável a não usá-lo. A melhor resolução é png para imagens 
importadas. O wmf aumenta muito o arquivo , e a melhor compressão de imagens no flash 
é a swf ( do próprio flash ) 
 
Observações : 
 
1. Quando você importa um arquivo ele vem com bitmap > perde qualidade e cresce o 

tamanho do movie. 

mailto:abc@provedor.com.br
http://www.macromedia.com/


2. Não vale a pena vetorizar na maiorias dos casos no flash , pois perde a resolução ; uma 
maneira seria antes de importar, salvar sua imagem num editor de imagens como bmp e 
depois importar para o Flash 

3. Quando você copia (Ctrl+C) do Corel/Free Hand e cola (Ctrl+V) no flash , ele vem com 
o vetorial, a qualidade fica boa mas também fica muito grande o movie 

4. Use as ferramentas de desenho do Word 97 que com elas podem fazer desenhos 3d , e 
quando você copia e cola no flash o arquivo vem bem pequeno : 
No Word  - criei um quadrado e ativei o 3D > Crtl + C > Flash3 > Ctrl + V > Modifty > 
Break Apart  duas vezes ou Crtl + B e agrupe a imagem Crtl + G 
Caso faça um desenho chapado no Flash copie e cola no Word 97 e use as ferramentas 
de desenho e coloque em 3d  

5. No Corel – as imagens feitas no Corel em WMF (Windows Meta File). 
6. No Photoshop – as imagens devem ser feitas em GIF  
7. No Freehand - as imagens devem ser feitas usando o comando ANIMATE do Xtras e 

depois exporta para SWF e importa no Flash 3 
  

COMO IMPORTAR UMA GIF DE OUTRO PROGRAMA 
 
1. File > Import 
2. Existem quatro opções para trabalhar com uma imagem importada : 

Background 
Usar dentro do desenho uma gif 
Vetorizá-lo 
Quebrá-lo para simular transparência 

3. Selecione toda a imagem importada 
4. Ctrl B ou  Modify > Break Apart 
 
Observação : Quando se importar uma imagem ela logo será inserida na sua Library ;  
 
1. Clique em Windows > Library ou Crtl + L 
2. Caso queira substituir esta imagem por outra, clique no pop-up ( seta ) da Library e 

escolha a opção properties 
3. Clique no item Import e importe a imagem que irá substituir a que foi inserida 

anteriormente 
4. Clique OK 
 
USANDO COMO BACKGROUND 
 
1. File = Import  o background 
2. Arrasta para o canto superior ( do lado esquerdo ) e com a tecla da seta para fazer os 

ajustes necessários 
3. Para alterar o background da imagem : Modify > Movie 
 
COMO VETORIZAR UM BITMAP 
 



1. Modify > Trace Bitmap 
2. Abrirá uma Caixa de diálogo : Trace Bitmap 

• Color Threshold para controlar a sensibilidade do trace aos meio tons, ou seja, 
quanto mais alto o valor, mais o seu vetorial se aproximara do número de cores 
existentes no bitmap. 

• Minimum area - é a área mínima para o trace ; quanto menor valor , menor será os 
detalhes que esteja trabalhando com uma imagem .  

• Curve fit – é a definição de como trace interpretará as curvas da imagem que pode 
ser : Pixels , Very Tight ( Muito Apertado ) , Tight ( Apertado ) , Normal , Smooth ( 
Suave ) , Very Smooth ( Muito Suave ).  

• Corner Threshold – é a  definição dos cantos das curvas da imagem que pode ser : 
Many Corners ( Muitos Cantos ) , Normal  e Few Corners ( Poucos Cantos ) 

 
Observação :  Quanto maior a resolução do seu bitmap e mais contraste 
de cores houver, melhorar será para o Flash traçar as curvas . 
 
RECURSO PARA OTIMIZAR AS CURVAS DE UMA IMAGEM 
 
Modify > Curves > Optmize ou Ctrl + Alt + Shift + C  ; elimina as curvas desnecessárias 
 
Observação : A qualidade de uma imagem importada para o Flash e depois exportada com 
extensão swf , em algumas vezes, geram manchas ou distorções indesejáveis ; para 
contornar isto : 
 
1. File > Export Movie 
2. Abrirá uma caixa de diálogo : 
3. No item JPEG Quality se controla o nível de compressão JPEG 
 
20 – EFEITO TRANSPARÊNCIA 
 
USANDO O BREAK APART PARA SIMULAR TRANSPARÊNCIA 
 
1. File > Import 
2. Selecione a imagem 
3. Ctrl B ou  Modify > Break Apart 
4. Clique na ferramenta Lasso 
5.  Clique na Segunda varinha mágica  
6. Abrirá uma Caixa de Diálogo : 
7. No item Threshold ( Abertura ) = 10  ; querendo mais precisão reduza o  numero. 
8. No item a suavidade  (Smoothing ) ( Suavidade ) normal  
9. Clique na primeira varinha, 
10. Clique nas áreas que você quer retirar de sua figura ;  
11. Selecione a área que deseja fazer simular transparência 
12. Clique Delete  
 



USANDO TRACE BITMAP PARA SIMULAR TRANSPARÊNCIA 
 
1. Outra forma para simular transparência : para vetorizar  Modify > Trace Bitmap  
2. Deletar as imagens da imagem da mesma forma 
3. Clique fora da figura para deselecionar 
 
Observação :   
 
1. Para dar efeito fundo transparente  : crie sua animação com um fundo preto e salva ; 
2. Só funciona em Windows e Internet Explorer versão 4.0 em diante ; 
3. As cores aceitas para transparência no Flash são as cores que estão na paleta de cores do 

Flash. 
4. No código html colocar os parâmetros :  
 
  <PARAM NAME=”wmode” VALUE=”transparent”> 
 

WTEXTO COM EFEITO ALPHA 
 
1. Veja exemplo anexo : textoalpha.fla  
2. Coloque um fundo escuro como background 
3. Crie um layer : Texto 1 
4. Digite um texto com uma cor diferente do background 
5. Selecione todo o texto > F8 ( x ) Movie Clip 
6. Edit = Color Effects = Alpha 
7. Vai fazendo frame por frame começando com Alpha = 10% 
8. O último frame = 100 % 
9. Insira Tweening entre todos os frames 
10. Selecione todos os Frames Edit > Copy Frame ou Crtl + Alt + C 
11. Insira um KeyFrame após o último frame 
12. Edit > Paste Frame ou Crtl + Alt + V 
13. Insira Blank Keyframe ou F7 
14. Insira outro Layer : Texto 2 
15. Repita o mesmo processo feito com o texto 1 
16. Crtl + Enter e teste sua animação 
 
VETORIZANDO UMA IMAGEM 
 
Isto serve para transformar um arquivo de imagem em arquivo flash ; sem Break Apart não 
se pode vetorizar e vice-versa. 
 
1. Moditify > Trace Bitmap ; quanto menor o color Threshold melhor será a definição. 
2. Clique OK 
3. Desenhe 
4. Com o botão direito = Selecet All 
5. Clique F8 para criar símbolo 
 



CRIAR IMAGEM TRANSPARENTE NO COREL 
 
1. Criar um gif transparente no COREL e importá-lo no Flash com o fundo realmente 

transparente.  
2. Crie um desenho 
3. As áreas que queira deixar transparente, coloque um preenchimento em preto; 
4. Mande exportar a imagem no COREL para *.gif; 
5. Selecione > Transparente 
6. Clique OK 
7. Aparecerá três botões : um desses botões é um conta gotas. 
8.  Clique no conta gotas 
9. Na imagem original e clique na cor preta onde queira que fique transparente. 
10. Clique OK 
11. Importe no Flash  
 
Informações sobre background transparente: 
 
http://www.macromedia.com/support/flash/how/subjects/wless2/wless02.html  
 
 
21 - S O M 
 
COMO COLOCAR SOM NUM LAYER 
 
1. O Fash só aceita sons com extensões wav e avi 
2. Libraries > Sounds 
3. Selecione o som 
4. Arraste para o desenho e não para o frame 
 
Caso queira importar um som de outro arquivo : 
1. File = Import 
2. Window = Library 
 
COMO IMPORTAR E EDITAR SOM 
 
1. Clique com o botão direito sobre o arquivo wav. 

Escolha a opção abrir, e não reproduzir. 
No menu do gravador de som escolha Editar > Propriedades de áudio 
Na janela que vai abrir, lá embaixo clique em Personalizar. 
Ai vai abrir outra janela... Escolha Formato PCM ai embaixo escolha os atributos, use 
11.000 hz para efeito e 22.000 hz para musica e escolha a opção com menos kb/s. 
Escolha aplicar e salve 

2. Import = Sound ( wav ) 
3. Insert = Sound 
4. Sound = seta para baixo e clique no som que foi importado 
 

http://www.macromedia.com/support/flash/how/subjects/wless2/wless02.html


• Fade in = o som vai aumentando devagar 
• Fade out = o som vai diminuindo devagar 
• Custom = para que você defina 
• Loop = digite a quantidade de repetição do som 
• Zoom in = out = para ver melhor a janela do som e movimentando as guias do som para 

cima e para baixo para dar um efeito nas duas caixas de som 
 
Exemplo : 
 
No primeiro quadrado = 1 guia permanece onde está e a segunda desce 
No segundo quadrado = 1 guia desce e a Segunda permanece onde está 
 
Som em Stream = o som fica presa a linha do tempo ao parar a execução da animação para-
se o som.  
 
Som em Event o som é executado quando a animação passa no keyframe onde ele esta., 
mas continua tocando até o final da música, mesmo que a animação tenha já sido toda 
executada.  
 
PROPRIEDADES DO SOM 
 
1. Libraries > Sounds ou Window > Library  
2. Selecione o som desejado 
3. Abrirá Caixa de Diálogo : Sounds 
4. Clique na Seta para baixo = Properties e defina a exportação e a compressão do som 
5. Sound : especifica o nome do arquivo 
6. No rodapé : 1º botão = parar ; 2º botão = tocar ; 3º botão = zoom + ; 4º botão = zoom - 

; botão do relógio = exibe na linha do tempo em segundos a duração do som e no botão 
do filme = exibe na linha do tempo em quantos frames roda o som 

7. Aumentar e diminuir o volume do som : quando você está na caixa de edição de som , 
nela pode controlar alguns efeitos de fade-in e fade out nestes sons : 
• No quadrado sobre a linha do som ,clique ao lado esquerdo do quadrado para gerar 

outro.  
• Mova esta novo quadrado para o começo, no nível mais baixo para criar um fade-in.  
• Faça o inverso no final do som para o fade-out.  
• Fade in é o som entrando aos poucos 
• Fade out é o som abaixando aos poucos 
• No item Syn ( Sincronização ) : o Event é o default do Flash , isto é o som continua 

até o final 
• No item Syn  : o Stream fica preso a timeline ( linha do tempo ) , isto é, o som 

termina quando para de rodar a animação 
 
Observação : O melhor formato para Wav - 22 kHZ - 16 bits MONO - PCM ou ADPCM , 
pois apresenta uma relação mais aprimorada entre Qualidade X Kbytes. Para som incidental 
usar 11 kHz 
 



 
PROGRAMA QUE TRANSFORMA MIDI EM WAV  
 
http://www.goldwave.com  O programa chama-se GoldWave 

 
22 - EFEITO TWEENING SHAPE  
 
O Tweening Shape a imagem tem que ser  vetorizada e não  pode ser transformada símbolo  
e apesar de ser mais lento em imagens bitmaps, dá um efeito interessante quando aplicado  
em números  e depois de transformados em símbolos . Cria Efeitos Morph na qual formas 
suaves dentro de novas formas em se tratando de animações complexas de imagens bem 
pequenas . Tweening shapes só é usado em elementos desagrupados 
 
1. Selecione dois KeyFrames da Imagem que queira fazer Shape 
2. Properties > Shape 
3. No item Blend Type ( Tipos de Mistura ) há duas opções : 

Distributive ( Distributivo ) cria uma animação na qual tamanhos intermediários são 
mais brandos e mais irregulares 
Angular cria uma animação que preserva a aparência dos cantos e das linhas retas nos 
tamanhos intermediários 

 
Shape ( x) Disolvation 
In – animação para dentro 
Out – animação para fora 
Reverse Frame – Loop Completo 
 
Tweening > Shape > Angular fica melhor em formar que tenham muitos cantos, dobras e 
linhas retas, assim a animação fica melhor, para os traços não "quebrarem" muito. 
  
 
Tweening > Shape > Distributive  pega as formas no meio da animação e as deixa mais 
suaves, mas muito irregulares e na maior parte das animações, não faz diferença; só fará 
diferença em animações que contenham muitos cantos e retas 
 
EFEITO SHAPE HINTS 
 
1. Faça uma animação usando Shape 
2. Selecione o primeiro Keyframe na sequencia do Shape 
3. Modify > Transform > Add Shape Hints ou Crtl + H 
4. Automaticamente aparecerá um circulo vermelho no objeto 
5. O último Keyframe do Shape aparecerá um círculo verde 
6. Mova o Shape Hint para o ponto no último shape que poderia corresponder o primeiro 

ponto que você marcou  
7. Crtl + Enter 
8. Para adicionar outros Shape Hint aparecerão outras letras b, c,d ... 
 

http://www.goldwave.com/


Durante a criação do Shape Hints existe as seguintes opções : 
 
1. View > Show Shape Hints para visualizar todos os Shape Hints ; o layer e o Keyframe 

que contém shape hints devem ser o corrente para que os Hape Hints sejam visualizados 
; para remover um Shape Hint , desative este estágio 

2. Modifty > Transform > Remove All Hints para remover todos os Hints 
 

WSHAPE COM QUATRO ESTÁGIOS 
 
1. Veja exemplo anexo : shape1.fla  
2. Desenhe um quadrado em vermelho 6 x 6 
3. Desenhe o círculo em verde 
4. Desenhe um triângulo em azul  fazendo uma estrela 
5. Desenhe um triângulo maior em azul 
6. Insira um frame na linha 100 
7. Insira um layer acima 
8. Desenhe sobre o triângulo maior em azul e pinte da mesma cor 
9. Insira Blank Keyframe na linha 25 
10. Desenhe sobre  o quadrado em vermelho e pinte da mesma cor 
11. Insira Blank Keyframe na linha 50 
12. Desenhe sobre a estrela e pinte da mesma cor 
13. Insira Blank Keyframe na linha 75 
14. Desenhe sobre a bola e pinte da mesma cor 
15. Copie o Frame na linha 1 e cole na linha 100 
16. Esconda a layer das linhas 
17. Selecione da linha 1 até 99 > Properties > Tweening > Shape 
18. Crtl + Enter e teste sua animação 
 

WSHAPE HINTS 
 
1. Desenhe um quadrado 
2. Retire as bordas 
3. Insira um Keyframe  na linha do tempo = 5 
4. Selecionada a linha do tempo = 5 
5. Ative o botão Snap ( Imã ) 
6. Desenhe um triângulo dentro  do quadrado usando a ferramenta Pencil ( Lápis ) com 

linha reta 
7. Observe que a linha tem que fechar o desenho do triângulo 
8. Selecione a ferramenta seta e selecione a parte que queira retirar 
9. Clique em delete 
10. Faça o mesmo com a outra parte a ser retirada 
11. Selecione a linha do tempo 1 até 4> Properties > Tweening > Shape 
12. Selecione o quadrado do primeiro keyframe 
13. Clique em Modify > Transform > Add Shape Hints ou Crtl + H 



14. Aparecerá uma bola vermelha com a letra a e arraste a bola a até a parte de baixo do 
lado esquerdo 

15. Clique sobre o botão a com o mouse direito pressionado e Add Hints 
16. Aparecerá a bola b 
17. Arraste a bola b para o lado de cima  
18. Insira outro Hints ; bola c 
19. Arraste a bola c a até a parte de baixo do lado direito 
20. Posicionar hints no sentido horário 
21. Selecione o triângulo do segundo keyframe 
22. Mova as bolas c, b e a que estão na cor verde na mesma proporção usada anteriormente 

, mas desta vez devem ser posicionados no sentido anti-horário 
23. Crtl + Enter e teste sua animação 
 
23 - CENAS = SCENES 
 
Para fazer uma animação no flash com mais de uma cena. 
 
1. Insert > Scene 
2. Aparecerá uma pasta do lado direito da tela > Scene 2 
3. Caso queira inserir outra cena > clique na pasta Scene 2 > Insert Scene > criará a Scene 

3 
4. Caso queira mudar o nome da Cena > clique na pasta da Scene 2 > Properties > e 

digite o nome desejado 
 
24 - AFTERSOCK 2.0 
 
Aftershock é um programa que permite configurar as animações em Flash os arquivo.fla 
transformando-os em arquivo.swf para inserir nas páginas HTML, gerando javascript para 
identificar o browser, a existência de plugin, e etc . um arquivo swf, pois ele compacta 
todos os layers, action, tweenings, etc. 
 
COMPOSIÇÃO DOS PARÂMETROS DO AFTERSHOCK 2.0 
 
SCRIPTING 
 
1 ) Scheme ( Esquema ) - Cada opção do Scheme é uma predefinição para rodar a 
animação 
 
Default 
Add Banner ( Adicionar Banner ) 
User Choice ( Escolha do Usuário ) 
Shockwave Only ( Somente Shockwave ) > recomendado que se use esta opção 
Use Java ( Uso de Java ) 
Custom  
 
2 ) Media Types ( Modelos Mídias ) 



 
ShockWave Plugin / Active x Control - Selecione essa opção caso queira que seu arquivo 
em flash rode usando o plug-in ou ActiveX no navegador do usuário, caso ele tenha 
instalado. 
Flash Player Java Edition  - Selecione se quiser usar o Flash Player em Java , caso o 
usuário não tenha o plug-in e seja necessário 
Static or Animated Gif ( Gif animada ou estática que substitui a animação em Flash, caso 
o usuário não tenha plugin ) 
 
3 )  User Preference ( Preferência do Usuário ) 
 
Allow user Cookie to Set Media Type -  permite ao usuário um Cookie para adaptar ao 
Modelo Mídia; este ajuste adiciona um código no HTML que verifica com um cookie as 
preferencias do usuário para rodar a animação ( com plugin ou ActiveX controle, como um 
java applet, como um GIF, ou como o que esta apropriado para cada situação ) e ajusta um 
cookie se nenhum existe.  
Caso selecione a opção Create Links to Choose Media Type ( Cria Links para escolha do 
Modelo Mídia ) - para que o AfterShock  automaticamente gere links para que o usuário 
faça a escolha. 
 
4 ) Instalation 
 
Active x Control on Internet Explorer ( rodar plugin para Internet Explorer  ) - Adiciona 
as tags <OBJECT> e <EMBED> necessárias para usar plugin do flash para rodar a 
animação. 
Pluggin on Netscape Communicator ( dar opção ao usuário para puxar o plugin do Flash 
caso ele esteja usando o Netscape e não tenha o plugin ) - Instala automaticamente o plugin 
do flash quando o browser do visitante for o Netscape Navigator 4.0 ou versão inferior 
 
5 ) JavaScript 
 
Enable Browser Scripting and FSCommand ( Ativar Script do Browser e do 
FSCommand ) - Habilita script do Browser e cria a função FSCommand em JavaScript e 
VBScript para receber comandos do Flash. 
 
PAGE LAYOUT 
 
1 ) Dimensions ( Dimensões ) : Width e Height - Largura e altura da animação em flash ( 
pixels ) 
      Mach Movie - Preenche automaticamente a altura e largura com as dimensões do filme 
 
2 ) Alignment ( Alinhamento ) - Selecione "Percentage" se quiser colocar as dimensões da 
animação em porcentagem relativa a área útil do browser 
 
3 ) Hyperlinks – List URL’s used in file.swf ( Lista de URL’s usadas no arquivo.swf ) - 
Gera uma lista das URLs usadas pelos GetUrl's e armazena em um comentário no fonte do 



HTML.  Esta lista permite que as ferramentas da verificação de links vejam e verifiquem se 
os links estão corretos 
 
4 ) Text – List Text  used in file.swf ( Lista de Textos usados no arquivo.swf ) - Gera uma 
lista do texto usado na animação em flash e armazena em um comentário no fonte do 
HTML.  Esta lista deixa os sistemas de busca verem e indexarem o texto. 
 
SHOCKWAVE 
 
1 ) Background ( Cor do Fundo ) - Escolha a cor de fundo do html 
 
2 ) Match Movie - Clique nesta opção para que a cor seja a mesma que a definida no filme 
 
3 ) Play back - Coloca na tag <embed>, respectivamente, os parâmetros play, loop, menu e 
device font. Para cada opção checada, o AfertShock ajusta o parâmetro como TRUE ou  
FALSE. 
• Paused at Start ( Parado no Começo )  - Para que a animação fique parada no primeiro 

frame quando carregar 
• Loop ( Quantas vezes irá rodar ) - Deixa a animação  em Loop , isto é, volta para o 

início quando chegar ao fim 
•  Display Menu ( Exibir Menu ) - Habilita que apareçam as opções no menu de controle 

da animação  se clicar com o botão direito do mouse no mesmo. 
• Device Font ( Dispositivo da fonte ) 
4 ) Quality ( Qualidade ) : Low ( Baixa ) ; Auto Low ; Auto High ; High ( Alta ) ; define 
qual a qualidade da animação se exibirá quando carregada.  
 
Low ou High para qualidade baixa ou alta, respectivamente. Use low quando for mais 
importante a velocidade do filme do que a qualidade e vice-versa. 
Auto Low e Auto High servem para dar prioridade para baixa ou alta resolução, 
respectivamente, mas mudam automaticamente a qualidade para que a velocidade não seja 
prejudicada. 
Recomendável a opção : High 
 
5 ) Windows Mode 
 
Windows ( Janelas ) - Ajusta o valor de parâmetro de WMODE como WINDOW e roda a 
animação no próprio retângulo da janela em uso. Este ajuste fornece normalmente o 
desempenho o mais rápido da animação. 
Opaque Windowsless ( Janelas Opacas ) - Ajusta o valor de parâmetro de WMODE a 
OPACO. Use este ajuste se você quiser mover elementos atrás das animações em  flash 
(por exemplo : Usando DHTML ) e não os quiser mostrar completamente. 
Transparent Windowsles ( Janelas Transparentes ) - Ajusta o parâmetro de WMODE a 
TRANSPARENTE. Use este ajuste para fazer o fundo do HTML aparecer nas partes 
transparentes da animação e pode ficar mais lento caso você faça o ajuste.  
 
6 ) Scale ( Escala ) 
 



Default ( Show All ) – Mostra todas as escalas ,ou seja , faz o visível toda a animação na 
área especificada ao manter a relação de aspecto original da animação.  
 
No border – nenhuma borda ; funciona como o Show All, mas não permite que as bordas 
apareçam. 
Exact fit – a animação será encaixada na janela do browser de quem estiver vendo, se por 
um acaso, a animação tiver 300x300, ela ocupará todo o espaço, mesmo que distorça a 
animação. Ajusta a animação para encaixar exatamente com o tamanho da janela, não 
mantendo as proporções originais da animação o que causará uma distorção 
 
7 ) Alignment ( Alinhamento ) 
 
ALTERNATIVE IMAGE ( Imagem Alternativa ) 
 
1 ) Gif Type : Static ( Imagem Estática ) e escolha no item frame a imagem que irá ser 
Estática caso não tenha plugin do Flash 
 
 2 )  Gif Animated ( Imagem Animada ) e escolha entre que frames rodará a animação caso 
não tenha plugin do Flash 
 
3 ) Width ( Largura ) e Height ( Altura ) que a animação exibirá na página HTML 
 
4 ) Interlace ( Entrelaçar ) - Faz a imagem ir aparecendo conforme for sendo carregada, no 
sentido de cima para baixo. 
 
5 ) Dither - Tenta preservar a aparência do original . Esta opção está deselecionada por 
default, permitindo que as cores continuas desloquem as cores seguras do browser o mais 
próximo se necessário.  
 
6 ) Transparent ( Transparente ) - Define o gif como transparente, permitindo ver o fundo 
da página nas áreas não coloridas 
 
7 ) Smooth ( Suave ) - Suaviza as bordas das imagens 
 
JAVA 
 
1 ) Use Java on ( Usar Java em ) - Determina se a versão de Java da sua animação que está 
sendo usada em todos os browsers Java-permitidos, ou somente naqueles com suporte 
robusto a Java (geralmente na versão 4.0 e browsers mais elevados).  Se você escolher uns 
browsers mais novos com suporte robusto a Java, a imagem alterna do GIF estará usada no 
lugar da versão de Java de seu filme para usuários com browsers mais velhos e nenhum 
plugin do flash. 
 
Newer Browsers with Robust Java Support ( Os mais recentes Browsers com Suporte 
em Java ) 
All Java Enabled Browsers ( Todos os Browsers que tenham habilitados os arquivos em 
Java ) 



 
2 ) Class File Location ( inserir um arquivo Java ( arquivo.class ) que substitua o 
arquivo.swf ) - Determina o path para o arquivo Flash.class que o Java precisa para rodar a 
animação em Flash. 
 
3 ) Class Files ( Arquivos das Classes ) - Determina como as os arquivos .class são 
comprimidos e empacotados.  
 
Para assegurar-se de que os arquivos estejam disponíveis ao número maior dos 
usuários, selecione todas as 3 opções : Flash.cab, Flash.jar e Flash.zip 
 
1. Packaged in Cab File for Internet Explorer ( Pacote do Arquivo Cab para o Internet 

Explorer ) 
2. Packaged in Jar File for Netscape 4 ( Pacote do Arquivo Jar para o Netscape 4 ) 
3. Packaged in Zip File for Netscape 3 ( Pacote do Arquivo Zip para o Netscape 3 ) 
  
Mas observe que quando transferir sua animação para o servidor , tem que levar os arquivos 
Flash.cab, Flash.jar e Flash.zip; nem todos os "host" deixam transferir o arquivo .jar por 
questões de segurança. 
 
Observação : use (width) 550 X (height) 400 , pois dá uma proporcionalidade muito boa 
para as configurações de tela mais comuns: 640X400 e 800X600. 
 
COMO INSERIR UM ARQUIVO SWF EM UM DOCUMENTO HTML 
 
1. Abra o AfterShock 2.0 
2. Clique no primeiro ícone : Add Shockwave 
3. Procure o arquivo.swf que queira inserir num documento html 

** Todas as vezes que damos Crtl + Enter e testamos uma animação, ela cria um 
arquivo com o mesmo nome com extensão swf ; exemplo : beto.fla >>> beto.swf 

4. Veja pastas do lado direito 
5. Scripting  

Scheme > Only Shockwave 
Media Types > Shockwave Plug-in / Active X Control 
Installation > Active X Control on Internet Explorer e Plug-in on Netscape 
Communicator 

6. Page Layout 
Deixe como está ! 

7. Shockwave 
Quality > High 

8. Alternative Image 
Deixe como está ! 

9. Java 
Desmarque todos os itens 

10. Clique no ícone Save ( disquete ) e salve seu documento em html ; ele cria 
automaticamente um script 

11. Dê um nome para sua página com extensão htm 



12. Ele abrirá automaticamente seu browser 
 
Observações : Caso queira mudar algum comando em HTML abra os recursos do 
documento e modifique manualmente ; quando for enviar a página  para seu Servidor : 
enviar o documento em HTML e o arquivo.swf que esteja inserido na mesma. Nunca 
envie o arquivo.fla ! 
 
25 - MÁSCARA 
 
Mask Layers ou Layers de máscara  são partes da animação na qual se pode definir partes 
visíveis e invisíveis , ou seja, é necessário que haja dois layers : o primeiro será a parte do 
objeto que será exibido e o segundo será exibido somente quando a mascara passar sobre 
ele. 
 

WEFEITO SPOTLIGHT 
 
1. Veja exemplo anexo : spot.fla 
2. Nomeie o layer de texto 
3. Desenhe um quadrado e pinte de cinza 
4. Retire as bordas 
5. Selecione o quadrado > Crtl + K 
6. Vertical > Align > marque terceiro botão 
7. Horizontal > Align > marque terceiro botão 
8. Match Size > marque o botão da cruz 
9. (x ) Align to Page 
10.Digite : Testando  ; em Arial Black , cor preta e tamanho 28 
11.Selecione o Texto > Crtl + K 
12.Vertical > Align > marque terceiro botão 
13.Horizontal > Align > marque terceiro botão 
14.Match Size > marque o botão do X 
15.(x ) Align to Page 
16.Selecione o texto > F8 > Name = texto ; behavior = graphic 
17.Insira um  frame na linha 40 > F5 
18.Insira um layer acima 
19.Nomeie o layer de spot 
20.Clique no lápis desde layer > botão à direita > Modify Layers > Hidden Others para 

esconder o layer texto 
21.Desenhe uma bola pintada de azul  
22.Selecione a bola > F8 > Name = bola ; behavior = graphic 
23.Clique no lápis desde layer > botão à direita > Modify Layers > Show All para mostrar 

o layer texto 
24.Arraste a bola para antes da palavra Testando 
25.Insira um keyframe na linha 40 e arraste a bola para depois da palavra Testando 
26.Selecione a linha do tempo 1 até 39 deste layer > Properties > Tweening > Motion 
27.Selecione a linha do tempo 1 deste layer ( Spot ) 
28.Clique no lápis desde layer > botão à direita > Modify Layers > Mask 



29.Clique no botão 12.0 fps e mude a cor do background para preto 
30.Crtl + Enter e teste sua animação  
 
Observações : 
 
• Para fazer uma animação com máscara,  deve haver sempre de dois layers 
• A máscara deve ficar no layer superior, e o objeto deve estar no layer inferior 
• Para selecionar o layer como mask, selecione o botão ao lado do nome do layer e 

selecione Mask 
• Ao selecionar a opção mask, automaticamente o layer imediatamente inferior fica na 

máscara 
• Para visualizar  o efeito funcionado, o layer Mask deve estar Trancado ( Locked ) 
 

WTEXTO EM DEGRADÊ 
 
1. Veja exemplo anexo : texto_degrade.fla  
2. Digite um texto 
3. Insira um layer abaixo 
4. Faça um retângulo 
5. Pinte em degradê 
6. Ative o primeiro layer 
7. Clique no pop-up e selecione mask 
 

WMÁSCARA COM TEXTO 
 
1. Veja exemplo anexo : mascara1.fla  
2. Digite um texto 
3. Selecione o texto > F8 e crie um símbolo gráfico : texto 
4. Faça outro keyframe na linha do tempo = 40 
5. Arraste o texto no segundo keframe para direita 
6. Insira Motion 
7. Insira novo layer na parte de cima 
8. Desenhe um retângulo e pinte por onde irá passar o texto 
9. Clique no pop-up e selecione mask 
10. Crtl + Enter e teste sua animação 
 

WMÁSCARA COM PADRONAGEM 
 
1. Veja exemplo anexo : mascara2.fla  
2. Desenhe uma padronagem 
3. Insira outro keyframe na linha do tempo 40 
4. Selecione tudo  e agrupe a padronagem Crtl + G 
5. Insira outro keyframe na linha do tempo 40 



6. Insira outro layer acima 
7. Digite o texto  
8. Selecione o texto > F8 e crie um símbolo gráfico 
9. Insira outro keyframe na linha 40 
10. Arraste o texto para um lado direito 
11. Selecione a linha 1 até 40 ref. layer do tetxo > Tweening > Motion 
12. Clique no pop-up  e selecione mask 
13. Crtl + Enter e teste sua animação 
 
26 - BANDWIDTH PROFILER 
 
PARA VISUALIZAR ESTA FERRAMENTA BANDWIDTH PROFILER 
 
1. Crtl + Enter para rodar sua animação 
2. View > Bandwith Profiler 
 
Band width profiler visualiza todo o conteúdo dos frames de uma animação, mostrando as 
imperfeições que podem prejudicar o download da animação , a velocidade do modem que 
você especificar 
 
• Cada  barra clara e barra escura é um frame individual da animação 
• O tamanho da barra escura corresponde ao tamanho do frame em bytes 
• Se a barra está acima da linha vermelha, a animação deve esperar que o frame seja 

carregado 
• No modo streaming  exibe uma região verde que mostra os número de frames 

carregados durante a exibição do corrente frame 
• Para efetuar ajustes na animação : 

• Control > Show Streaming para ativar ou desativar determinada barra 
• View > Streaming Graph para visualizar qual frame será a causa das pausas 
• View > Frame by Frame para visualizar o tamanho de cada frame 

 
PARÂMETROS DA BANDWIDTH PROFILER 
 
Movie ( Animação ) 
 
Dim = Dimensão em pixels 
Fr rate = quantos frames por segundo 
Size = Tamanho em KB 
Duration = duração de 1 frame por segundo 
Preload é o tempo que vai demorar para baixar na web , ou seja todos os frames por 
segundo 
 
Settings  ( Ajustes ) 
 
Bandwidth seleciona o tipo de modem 
 



State ( Estado )  
 
Como reduzir o tempo de download de um arquivo.swf 
 
• Para ver o tamanho e o tempo de download com diversas conexões: 14,4 , 28,8 , 33,6 

56 ISDN, etc usando o recurso de Bandwidth Profile do Flash 3. 
• Para reduzir o tempo de donwload : use sucessivos if frame is load ou usando varios 

movies usando load movie. 
 
27 - MOVIE CLIP 
 
COMO CRIAR UM MOVIE CLIP 
 
1. Windows > Library > Create Symbol 
2. Name : dê um nome ; behavior marque  ( x ) movie clip 
3. Faça seu movie clip normalmente usando vários keyframe 
4. Clique na seta azul ( à direita da tela ) para sair da edição do movie clip e voltar a área 

de trabalho 
5. Mantendo Windows > Library aberta 
6. Arraste o movie clip para área de trabalho 
7. Crtl + Enter e teste sua animação 
 
Exemplo de Movie Clip 
 
1. Na animação principal  tem um botão e nesta animação que tem um load movie no 

actions  
2. Insira um keyframe logo após este keyframe onde se encontra o botão, que deve ficar 

com 2 frames exatamente iguais um seguido do outro 
3. No segundo  keyframe edite as propriedades do botão e mude na parte " Definitions" de 

button para graphic e coloque single frame. 
4. Volte no frame anterior e adicione um Goto next frame antes do Load movie no botão, 

o que era: 
 
 On(Release) 
  Load Movie 
 End On 
  
 Deve ficar: 
 
 On(Release) 
  Goto and Stop /*next frame*/ 
  Load Movie 
 End On 
 
Quando o usuário apertar o botão, a animação avança um frame, neste frame o botão estará 
desativado, e então carrega a animação 



 
COMO TRANSFORMAR UM ARQUIVO.FLA EM MOVIE CLIP 
 
1. Selecione os frames de todos layers que queira transformar em movie clip e aplique 

Copy Frames. 
2. Crie um novo arquivo >  Insert > Create Symbol > novo símbolo tipo movie clip  
3. Dê um nome a este símbolo.  
 
Outra maneira :  
 
1. Criar uma cena nova e na única frame da única layer insira uma instância do símbolo 

criado  a partir da Library .  
2. Teste a cena. 
3.  Se tudo estiver rodando perfeitamente , delete a cena original. 
 

WBARRA DE ROLAGEM 
 
1. Veja exemplo anexo rolagem.fla  
2. Crie um símbolo gráfico com o texto que vai rolar na barra de rodagem 
3. Insira um keyframe na linha 2 
4. Insira um keyframe na linha 30 e movimente o texto para a parte de cima 
5. Insira motion entre a linha 2 e 29 
6. Insira um layer acima 
7. Na linha 1 > blank keyframe > action > Go to Next Frame 
8. Na linha 2 > blank keyframe > action > Stop 
9. Na linha 31 > blank keyframe > action > Go to Previous Frame 
10. Volte ao layer do texto e clique na linha 30 
11. F5 para a linha andar uma vez até a linha 31 
 
2ª PARTE - SUBIR 
 
1. Crie um novo símbolo como movie clip e arraste a seta > Circle with arrow 
1. Insira a seta e a selecione > modify > Flip Horizontal   
2. Modify > Scale and Rotate > Rotate = 90  ( Seta para Cima ) 
3. Crie um layer acima 
4. Na linha blank keyframe > Action > Stop 
5. Insira outra blank keyframe na linha 2 > Action > 
6. Tell Target  > target = ../rolar 
7. Go to Previous Frame 
8. Insira outra blank keyframe na linha 3 > Action > Go to and Play > 

 number = 2 
9. Insira a frame na linha 4 
10. Clique no símbolo seta > Properties > Actions 
11. On Mouse Events  > Press and Drag Over 
12. Go to and Play > number = 2 
13. On Mouse Events > Press and Drag Out 



14. Go to and Stop > number = 1 
 
3ª PARTE  - DESCER 
 
1. Crie um novo símbolo como movie clip e arraste a seta > Circle with arrow 
2. Insira a seta e a selecione 
3. Modify > Scale and Rotate > Rotate = 90 ( Seta Para Baixo ) 
4. Crie um layer acima 
5. Na linha blank keyframe > Action > Stop 
6. Insira outra blank frame na linha 2 > Action > 
7. Tell Target = target = ../rolar 
8. Go to Next Frame 
9. Insira outra blank keyframe na linha 3 > Action > Go to and Play > 

 number = 2 
10. Insira a frame na linha 4 
11. Insira a frame no layer da seta na linha 4 
15. Clique no símbolo seta > Properties > Actions 
16. On Mouse Events  > Press and Drag Over 
17. Go to and Play > number = 2 
18. On Mouse Events > Release and Drag Out 
19. Go to and Stop > number = 1 
 
4ª PARTE 
 
1. Crie um novo símbolo  
2. Insira o o símbolo do texto como Movie Clip 
3. Clique sobre o texto > Properties 
4. Edit > Definition > Instance  Options = rolar 
5. Insira as duas setas 
6. Desenhe um retângulo por onde irá passar o texto e pinte da mesma cor 
7. Insira máscara 
8. Volte para área principal e insira o símbolo do texto/seta 
9. Insira a frame no layer da seta na linha 4 
10. Crtl + Enter e teste sua animação 
 
28 - BOTÕES AVANÇADOS 
 
EFEITO PARA BOTAO 
 
1. Coloque para cada instância de botão ativo em uma layer diferente  
2. Crie keyframes onde há só um botão  ou 
3. Desative o botão por meio de uma forma com preenchimento sólido (símbolo tipo: 

"gráfico") que deve ficar no movie carregado, cobrindo perfeitamente a área Hit do 
botão a ser desativado ( que está no movie básico). Depois, clique 2 vezes sobre a 
instância do gráfico e mude o seu comportamento ("behavior") para botão ("button"). 
Use uma instância para cada botão a ser desativado e repita tudo de novo. 



 
BOTÃO INVISÍVEL 
 
• Um botão invisível é aquele que não tem nada no estágio Up  
• Pode-se fazer o efeito de aproximação fazendo um botão invisível com um frame Hit 

em forma de circulo – só as bordas e sem preenchimento - no seu movie duplique várias 
vezes esse botão e vá diminuindo o tamanho dele e centralize o botão através Crtl + K 

 
COMO FAZER BOTÃO INVISÍVEL 
 
1. Crie um  símbolo chamado Teste e behavior = button 
2. Deixe os estágios  Up, Over e Down vazios 
3. No estágio Hit faça um quadrado 
4. Feche a edição do botão ( seta azul ) 
5. Window < Libray e selecione o símbolo botão chamado Teste que está invisível 
6. Arraste o símbolo para a área de trabalho 
7. Ele aparecerá na cor ciano claro 
8. Crtl + Enter e teste sua animação 
 
BOTÃO AVANÇADO : CINCO ESTÁGIOS  "REPLACEMENT METHOD"  
 
1. Windows > Library > Create Symbol 
2. Name : invisivel ; behavior : button 
3. Selecione o estágio Up e desenhe o botão 
4. Insira Keyframe nos estágios Over , Down e Hit 
5. Insira um frame depois do estágio Up  que é quinto estágio do botão  
6. Selecione o estágio Hit e apague a figura que apareceu igual à do estágio Hit 
7. Insira e alinhe a imagem da figura que escolheu para substituir o botão eliminado  
8. No frame específico da barra de navegação , modifique o comportamento da instância 

do botão a ser desativado para "graphics" e o Play Mode  para "Single Frame" e "Start 
Frame:"  

9. Não precisa editar a ação 
 
 
BOTÃO AVANÇADO 
 
1. Criar 3 Movie Clips , sendo que um deles seja diferente dos outros dois 
2. Escreva um texto no botão 
3. Uma transparência de esfera gráfica 
4. Dois arquivos de som para os estágios OVER e DOWN 
5. Desenhe um círculo e pinte 
6. Insert>Create Symbol 
7. Na Caixa Das Propriedades do Símbolo 
8. No item Name : digite Botão em Espiral 
9. No item behavior ( x ) Button 
10. Em cada Estágio vá acrescentando layers abaixo de desenhando formas diferentes para 

seu botão 



 

WBOTÃO COM MÁSCARA 
 
1. Veja exemplo anexo : botao_mascara.fla 
2. Windows >Library > Create Symbol 
3. Name : texto ; behavior : graphic 
4. Digite :  

CLIQUE AQUI PARA 
OBTER INFORMAÇÕES 
DE NOSSOS SERVIÇOS ... 
NOSSOS CLIENTES ... 
PROMOÇÕES ... 
E AS ÚLTIMAS NOVIDADES !!!! 

5. Selecione o  texto > Crtl K para alinhar 
6. Vertical > Align ( x ) terceiro botão 
7. Horizontal > Align ( x ) terceiro botão 
8. Match Size marque ( x ) 
9. Marque Align to Page 
10. Windows > Library > Create Symbol 
11. Name : máscara ; behavior : movie clip 
12. Selecione o símbolo texto e arraste para a área de trabalho do símbolo máscara 
13. Selecione o texto > Crtl K para alinhar 
14. Vertical > Align ( x ) terceiro botão 
15. Horizontal > Align ( x ) terceiro botão 
16. Match Size marque ( x ) 
17. Marque Align to Page 
18. Insira um keyframe na linha do tempo 40 e arraste o tempo para cima 
19. Selecione a linha do tempo 1 até 39 > Properties > Tweening > Motion 
20. Insira um layer acima do texto 
21. Desenhe um retângulo por onde irá passar o texto e pinte de branco 
22. Selecione o retângulo de modo que ele esteja no início do texto 
23. Clique no ícone Modify Layer ( ao lado dos layers ) > Mask 
24. Windows > Library > Create Symbol 
25. Name : botão ; behavior : button 
26. Desenhe uma bola e pinte 
27. Selecione o  texto > Crtl K para alinhar 
28. Vertical > Align ( x ) terceiro botão 
29. Horizontal > Align ( x ) terceiro botão 
30. Match Size marque ( x ) 
31. Marque Align to Page 
32. Insira um keyframe nos estágios Over , Down e Up 
33. Selecione o estágio Over 
34. Windows > Library e arraste o movie clip máscara para o lado do botão 
35. Feche a edição dos botões ( seta azul ) do lado de cima à direita 
36. Arraste da Library o botão para área de trabalho 
37. Crtl + Enter e teste sua animação 



 
 
29 - TELL TARGET 
 
Tell Target envia ações para uma determinada instância de um símbolo. Instância é uma 
cópia de um símbolo que pode ser modificada tantas vezes forem necessárias, sem alterar a 
original. 
 
BOTÃO PLAYER PARA TRÁS USANDO TELL TARGET 
 
1. Crie um movie-clip com o nome clip1 e de sua única instância que rode animação  
2. Delete as layers da animação original e insira uma instância e atribua o nome de clip1 
3. Crie um outro movie clip com o nome clip2 , sem nenhuma imagem ou desenho, e com 

tantas keyframes quantas as do movie clip1. 
4. Em todos os frames do clip2  com exceção do último , use a  seguinte ação: 
 
Begin Tell Target (/mclip1) 
   Goto Previous Frame 
End Tell Target 
 
Coloque Stop no primeiro frame do clip2, mas não no clip1. 
 
• No último frame do clip1 , coloque a ação: 
 
Begin Tell Target (/mclip2) 
   Goto Frame 2 and Play 
End Tell Target 
 
Não precisa colocar Stop depois do End Tell Target 
 
• No último frame do mclip2 coloque a ação: 
 
Begin Tell Target (/mclip1) 
   Goto Frame 1 and Play 
End Tell Target 
 
Não precisa colocar Stop depois do End Tell Target 
 

WBOTÃO ANIMADO USANDO TELL TARGET 
 
1. Veja exemplo anexo : target1.fla 
2. Libraries > Movie Clip 
3. Insira um movie clip : Flish Movie Clip 
4. Libraries > Button 
5. Selecione o peixe > Crtl + D para duplicar o peixe e arraste para baixo  do visor 



6. Selecione o primeiro peixe > Properties > Definition 
7. No item Instance Name : digite peixe1 
8. Selecione o segundo  peixe > Properties > Definition 
9. No item Instance Name : digite peixe2 

 
10. Insira um botão :  Dial 
11. Selecione o Dial > Modify > Transform > Scale and Rotate 
12. Scale = 50 e Rotate = 0 
13. Selecione o Dial > Crtl + D para duplicar o botão Dial e arraste para o lado do peixe2 
14. Selecione novamente o Dial > Crtl + D para duplicar e arraste para o lado do peixe2 

 
15. Selecione o botão Dial do peixe 1 
16. F8 > e crie um novo símbolo : Name= Dial2 ; behavior = movieclip 
17. Clique duas vezes sobre o Dial 2 > Edit 
18. Com o símbolo Dial 2 aberto para ser reeditado 
19. Insira um keyframe na linha do tempo 2 
20. Selecione a linha do tempo 1 > Properties > Action > Stop 
21. Mantendo a linha do tempo 1 selecionada 
22. Clique no botão Dial 2 > Properties > Action 
23. On Mouse Events ; ( x ) Release 
24. Tell Target ; em target digite : ../peixe1 
25. Stop 
26. Selecione End Tell Target e clique em + 
27. Go to ; marque ( x ) Next Frame 

 
Ficará assim : 
On ( Release ) 
      Begin Tell Target 
          Stop 
      End Tell Target 
     Go to Next Frame 
End On 
 

28. Selecione a linha do tempo 2 
29. Clique no botão Dial 2 > Properties > Action 
30. On Mouse Events ; ( x ) Release 
31. Tell Target ; em target digite : ../peixe1 
32. Play 
33. Selecione End Tell Target e clique em + 
34. Go to ; marque ( x ) Previous Frame 

 
Ficará assim : 
On ( Release ) 
      Begin Tell Target 
          Play 
      End Tell Target 
     Go to Previous Frame 



End On 
 

35. Selecione o primeiro botão Dial do peixe2 
36. Properties > Action 
37. On Mouse Events ; ( x ) Release  
38. Tell Target ; em target digite : /peixe2 
39. Stop 

 
Ficará assim : 
On ( Release ) 
      Begin Tell Target 
          Stop 
      End Tell Target 
End On 
 
 

40. Selecione o segundo botão Dial do peixe2 
41. Properties > Action 
42. On Mouse Events ; ( x ) Release  
43. Tell Target ; em target digite : /peixe2 
44. Play 

 
Ficará assim : 
On ( Release ) 
      Begin Tell Target 
          Play 
      End Tell Target 
End On 
 

45.  Crtl + Enter e teste sua animação 
 

WTELL TARGET SINCRONIZADO 
 
1. Veja exemplo anexo : target2.fla 
2. Libraries > Movie Clip 
3. Selecione o Star Spinning e arraste para área de trabalho 
4. Arraste o mesmo movie clip mais três vezes > totalizando quatro Star Spinning 
5. Selecione o segundo Star Spinning > Properties > Color Effects 
6. Tint > e pinte de verde 
7. Selecione o terceiro Star Spinning > Properties > Color Effects 
8. Tint > e pinte de azul 
9. Selecione o quarto Star Spinning > Properties > Color Effects 
10. Tint > e pinte de roxo 

 
11. Selecione a estrela vermelha > Properties 
12. Definition > Instance Name : estrela1 



13. Selecione a estrela verde > Properties 
14. Definition > Instance Name : estrela2 
15. Selecione a estrela azul > Properties 
16. Definition > Instance Name : estrela3 
17. Selecione a estrela roxa > Properties 
18. Definition > Instance Name : estrela4 

 
19. Selecione a linha do tempo = 1 > Properties > Action 
20. Tell Target ; target : /estrela1 
21. Stop 
22. Selecione End Tell Target 
23. Insira outro Tell Target ; target : /estrela2 
24. Stop 
25. Selecione End Tell Target 
26. Insira outro Tell Target ; target : /estrela3 
27. Stop 
28. Selecione End Tell Target 
29. Insira outro Tell Target ; target : /estrela4 
30. Stop 

 
31. Windows > Library  
32. Clique na seta preta > Create Symbol 
33. Name : invisível ; behavior = movie clip 
34. Neste símbolo não irá desenhar nada, ele servirá apenas para comandar as ações do Tell 

Target 
35. Insira Blank keyframe na linha 15 
36. Insira Blank keyframe na linha 30 
37. Insira Blank keyframe na linha 45 
38. Insira Frame na linha 60 

 
39. Selecione a linha do tempo 1 > Properties > Action 
40. Tell Target ; target : /estrela1 
41. Play 
42. Selecione a linha do tempo 15 > Properties > Action 
43. Tell Target ; target : /estrela3 
44. Play 
45. Selecione a linha do tempo 30 > Properties > Action 
46. Tell Target ; target : /estrela4 
47. Play 
48. Selecione a linha do tempo 45 > Properties > Action 
49. Tell Target ; target : /estrela2 
50. Play 
51. Clique na seta azul ( à direita da tela ) para fechar a edição do símbolo 
52. Mantendo Windows > Library aberta 
53. Selecione o movie clip > invisível e arraste para o centro da tela 
54. Crtl + Enter e teste sua animação 
 



WBOTÃO – MENU HIERÁRQUICO 
 
1. Veja exemplo anexo hierarquico.fla 
2. Crie seis botões 
3. Primeiro botão = cadastro 
4. Segundo botão = serviços 
5. Terceiro botão = clientes 
6. Quarto botão = pesquisa 
7. Quinto botão = histórico 
8. Sexto botão = promoção 

** Todos os seis botões acima com estágios Up , Over, Down , Hit 
9. Crie três botões 
10. Primeiro botão = Item1 
11. Segundo botão = Item2 
12. Terceiro botão = Item 3 

** Todos os três botões acima com estágios Up e Hit 
13. Na área de trabalho ( canvas ) insira os botões : Item1, Item2 e Item3 
14. Nomeie o layer como menu 
15. Insira keyframe na linha do tempo 10 , 20 e 30 
16. Insira Frame na linha do tempo 40 

 
17. Insira uma layer acima do menu 
18. Nomeie o layer como submenu 
19. Insira blank keyframe na linha do tempo 10 
20. Insira os botões : cadastro e serviços ao lado do botão item1 

 
21. Insira blank keyframe na linha do tempo 20 
22. Insira os botões : clientes e pesquisa ao lado do botão item2 
23. Insira blank keyframe na linha do tempo 30 
24. Insira os botões : histórico e promoção ao lado do botão item3 

 
25. Insira um layer acima do submenu 
26. Nomeie o layer como label/ação 
27. Insira blank keyframe na linha do tempo 10, 20 e 30 
28. Insira frame na linha do tempo = 40 

 
29. Selecione o blank keyframe na linha do tempo = 1 

Properties > Label = início  e Action = Stop 
30. Selecione o blank keyframe na linha do tempo = 10 

Properties > Label = item1 
31. Selecione o blank keyframe na linha do tempo = 20 

Properties > Label = item2 
32. Selecione o blank keyframe na linha do tempo = 30 

Properties > Label = Item3 
 
 



33. Selecione a linha do tempo 1 do layer menu 
Clique sobre o botão item1 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = item1 

34. Selecione a linha do tempo 1 do layer menu 
Clique sobre o botão item2 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = item2 

35. Selecione a linha do tempo 1 do layer menu 
Clique sobre o botão item3 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = item3 
 

36. Selecione a linha do tempo 10 do layer menu 
Clique sobre o botão item1 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = início 

37. Selecione a linha do tempo 10 do layer menu 
Clique sobre o botão item2 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = item2 

38. Selecione a linha do tempo 10 do layer menu 
Clique sobre o botão item3 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = item3 
 

39. Selecione a linha do tempo 20 do layer menu 
Clique sobre o botão item1 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = item1 

40. Selecione a linha do tempo 20 do layer menu 
Clique sobre o botão item2 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = inicio 

41. Selecione a linha do tempo 20 do layer menu 
Clique sobre o botão item3 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = item3 
 

42. Selecione a linha do tempo 30 do layer menu 
Clique sobre o botão item1 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = item1 

43. Selecione a linha do tempo 30 do layer menu 
Clique sobre o botão item2 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = item2 



44. Selecione a linha do tempo 30 do layer menu 
Clique sobre o botão item3 > Properties 
On Mouse Events ( x ) Release 
Go to Stop e Label = inicio 

 
 
30 - FLASH COM JAVASCRIPT 
 
COMO INICIAR UMA FUNÇÃO JAVASCRIPT NO FLASH 
 
1. Crie seu JavaScript no documento HTML 
2. Abra o Flash 
3. Crie um botão e arraste para área de trabalho 
4. Clique no botão > Properties > Action 
5. Get URL ; no item URL : javascript:windows.open() 
 
Javascript – abrir uma nova Janela 
 
Ao clicar um botão , abrir uma nova janela  do browser com uma nova URL  
 
1. Faça uma Action > Get URL  
      Get URL          <javascript:AbreJanela(>javascript:AbreJanela()  
 
2. No arquivo Html que contém o arquivo Flash coloque as seguintes linhas:  
 
<script language="JavaScript"><!--  
function AbreJanela() {  
window.open('EnderecoDaSuaJanela','NomeDaSuaJanela','toolbar=no/yes,location=n
o/yes,directories=no/yes,status=no/yes,menubar=no/yes,scrollbars=no/yes,resizable=n
o/yes,width=TamanhoEmPixels,height=TamanhoEmPixels')  
}  
// --></script>  
 
Ou seja ..... 
 
<html> 
<head> 
 
<SCRIPT LANGUAGE="JavaScript"> 
function abrejanela(){ 
 cyber=window.open('Pagina_em_flash.htm', 'Nome_da_janela', 
 'toolbar=no,location=no,directories=no,status=no,menubar=no, 
 scrollbars=yes,resizable=no,copyhistory=no,height="100%",width="100%"') 
} 
</SCRIPT></head> 
 
<body> 



 
<a href="pagina_em_flash.htm" Onclick="abrejanela()" target="Nome_da_janela"> 
Clique aqui para abrir uma nova janela</a> 
 
</body></html> 
 
** No Internet Explorer a nova janela não é aberta em Fullscreen. ( tela toda ), basta apertar 
o botão de maximizar ; no Netscape funciona sem problemas 
 
COMO FAZER SEU FILME IR PARA O FRAME 20 E COMEÇAR A RODAR : 
 
<javascript> 
  flashObj = (navigator.appName=="Netscape") ? document.index : index; 
  flashObj.TGotoFrame('_flash0', 20); 
  flashObj.TPlay(); 
</javascript> 
 
Exemplo de páginas com JavaScript e ASP 
 
http://freeflight.cockpit.be/bertoflash  
 
http://www.altern.org/bertoflash/bertomai.htm
 
http://freeflight.cockpit.be/bertoflash/fa.asp
 

 
32 – EFEITO FRAME IS LOADED 
 
FRAME IS LOADED 
 
1. Selecione o frame no linha do tempo e escolha Modify = Frame 
2. Clique Actions na Caixa Frame Properties 
3. Escolha Is Frame is Load  no menu Actions 
4. Digite o número do frame e escolha frame label para ser checado 
5. Escolha a Scene do frame no menu Scene 
6. O resultado poderia ser algo assim : 
 
 Se o frame é carregado 
     Funcione 
 If Frame is Load é carregado 
 
Outra forma : 
 
Suponha que você deseja fazer o download no início que vai de 5 ao 100 frame 
 

http://freeflight.cockpit.be/bertoflash
http://www.altern.org/bertoflash/bertomai.htm
http://freeflight.cockpit.be/bertoflash/fa.asp


1. No frame 1 coloque Action Play 
2. No frame 4 coloque Go to ( and Play ) apontando para o frame 1 
3. No frame 3 coloque If Frame is Load e nas opções indique o frame e scene que você 

deseja, que neste caso é o frame 100 
4. No frame 3, entre Action Frame is Load e End Frame is Load insira uma outra Action , 

neste caso Go to ( and Play ) para frame 5 
5. O Flash passo pelo frame 3 e testa se o frame 100 já estiver carregado. Caso negativo 

passa para o frame 4 onde encontra uma Action que leva ao frame 1 novamente, 
permanecendo em loop. Quando chega no frame 3, o frame 100 já está carregado e ele 
passa ao frame 5 continuando a animação. 

 

WCARREGANDO IMAGENS 
 
1. Nomeie o layer = efeito ; digite o texto : Imagem Carregando 
2. Insert > Keyframe na linha = 10 
3. Na linha 1 = mova o texto para o alto ( no lado esquerdo ) 
4. Modifty > Rotate and Scale > Scale = 10 
5. Selecione linha 1 até a linha 9 > Properties > Tweening > Movie 
6. Clique na linha = 1 > Properties > Actions 
7. Is Frame is Loaded : 

Scene = Scene 1 
Frame = number : 13 

8. Go TO : 
Scene = Scene 1 
Frame = number : 2 
Control = ( x ) Go to and Play 

9. Insira um novo layer abaixo > titulo 
10. Na linha 10 > Insert > Keyframe > Faça o título 
11. Insert > Keyframe na linha 20 
12. Volte a linha 10 
13. Selecione todo o título > F8 > Name : abertura 
14. Modify > Scale and Rotate > 10 
15. Arraste para o lado esquerdo 
16. Selecione linha 10 até linha 19 > Properties > Tweening > Movie 
17. Selecione a linha 2 > Properties > Action > + 
18. Go to > Scene = Scene 2 ; Frame number = 111 
19. Selecione a linha 111 > Properties > Action > + > Play 
20. Selecione a linha 150 > Properties > Action > + > Stop 
21. Insira um layer abaixo do layer 1 
22. Nomeie de comentários 
23. Selecione a linha do tempo deste layer > Properties > Label > ( x ) comment 
24. E digite : neste exemplo a Cena 2 tem 150 frames 
25. Clique na orelha das Cenas do lado direito da tela e selecione Scene 1 
26. Digite : Imagem carregando ... 



 
WIMAGEM CARREGANDO 

 
1. Insert > Scene 
2. Aparecerá umas pastas do lado direito da tela 
3. Vamos trabalhar primeiramente na Scene 2 
4. Clique em 12.0fps duas vezes e coloque o background em azul escuro 
5. Digite : Testando o Efeito Frame is Loaded 
6. Clique na linha do tempo = 1 > botão direito > Properties > Action > + > Stop 
7. Clique na linha do tempo =2 > botão direito > Insert Blank Frame 
8. Insira Blank Keyframe na linha do tempo = 40 e depois na linha = 110 
9. Selecione a linha 40 até a 110 > e Insira Blank Keyframe 
10. Insira um keyframe na linha 111 
11. Desenhe uma bola 
12. Selecione a bola > F8 > Symbol : name = bola ; behavior = graphic 
13. Arraste a bola para o lado de cima à esquerda 
14. Insira um keyframe na linha 150 
15. Arraste a bola para baixo à direita 
16. Selecione a linha 111 até 149 > Properties > Tweening > Motion 
 

WFRAME IS LOADING 
 
1. Veja exemplo anexo load.fla 
2. Layer = foto 
3. Digite : Imagem Carregando ... 
4. Libraries > Movie Clip 
5. Animated Asteric e arraste objeto para área de trabalho 
6. Clique sobre o Objeto > Properties > Color Effects > Tint e pinte o objeto de azul 
7. Insira keyframe ou F6 na linha do tempo = 36 
8. Selecione : carregando imagem e delete e digite : está quase ... 
9. Insira frame ou F5 na linha do tempo = 50 
10. File > Import e insira uma foto 
11. Clique sobre a linha 36 com o botão direito do mouse > Label 
12. Digite em name : vai e marque label 
13. Clique sobre a linha 50 com o botão direito do mouse > Label 
14. Digite em name : foto e marque label 
15. Insira frame ou F5 na linha 70 
16. Insira um layer acima do layer foto e nomeie de controle 
17. Insira keyframe na linha 19 e 35 
18. Insira frame ou F5 na linha 70 
19. Clique sobre a linha 19 com botão direito do mouse 
20. Properties > Actions > + 
21. Is Frame is Load  e ( x ) label = foto 
22. Actions > + 



23. Go to e ( x ) , label = vai e ( x ) Go to and Play 
24. Clique sobre a linha 35 com botão direito do mouse 
25. Properties < Actions > + 
26. Go to , frame = 1 e ( x ) Go to and Play 
27. Crtl + Enter e teste sua animação 
 
 

WEXEMPLO COM DUAS CENAS 
 
1. Neste exemplo serão criadas duas Cenas 
2. CENA I  
3. Insert > Scene CENA 2  
4. Scene 1> Properties > Scene Properties > Name : Efeito  
5. Scene 2> Properties > Scene Properties > Name : Primeira Parte  
 
CENA 1 – Efeito 
 
1. Nomeie o layer : inicio 
2. Insert > Blank Keyframe na linha 1 
3. Na linha = 7 , insira Insert > Keyframe ou F6 
4. Faça um desenho e selecione-o > F8 
5. Dê o nome de símbolo : teste 
6. Na linha = 12 > F6 e mude a posição do desenho 
7. Insira outro Keyframe na linha 13 e digite : A imagem está quase carregando 
8. Insira outro Keyframe na linha 20 
9. Selecione Keyframe entre a linha 7 e 12 
10. Properties > Tweening > Motion  
11. Na barra cinza ref. a este layer > Add Motion Guide 
12. Foi criado automaticamente um layer com risco em azul claro 
13. Acione as ferramentas Onions e arraste as setas cinzas entre a linha 7 e 12 
14. Clique na ferramenta Pencil e selecione Pencil Mode 
15. Faça a trajetória entre as duas imagens unindo os pontos + de cada imagem 
16. Desative as Onions 
17. Clique a linha cinza do layer Motion Guide > Hidden para esconder este layer 
18. Insira novo Layer = Mensagem 
19. Digite um texto : Imagem Carregando .... na linha =1 
20. Na linha = 20 insira Clear Keyframe 
21. Salve seu trabalho 
 
CENA 2 – Primeira Parte 
 
13. Nome do layer : Texto com imagens 
14. Digite textos e coloque imagens 
15. Insira na linha do tempo = 2 > Blank Keyframe 
16. Insira outra Blank  Keyframe na linha do tempo = 40 
17. Insira outra Blank Keyframe na linha do tempo = 60 



18. Selecione a linha do tempo 40 à 60 > Insert > Blank Keyframe 
19. Na linha do tempo = 61; dê Keyframe > F6 e inicie outro desenho 
20. File > Import > alguma imagem 
21. Nomeie o Layer = Teste 2 
22. Modifty > Break Apart ou Crtl B 
23. Clique na ferramenta Lasso 
24. Clique na Segunda varinha mágica 
25. Abrirá uma Caixa de diálogo : 
26. No item Threshold ( Abertura ) = 10 ; para maior precisão reduza o Theshold 
27. No item Smoothing ( Suavidade ) deixa em normal 
28. Clique na primeira varinha 
29. Clique nas áreas que você queira retirar parte da figura para simular transparência 
30. Clique Delete 
31. Outra forma para simular transparência : para vetorizar Modify > Trace Bitmap 
32. Deletar partes da imagens da mesma forma mencionada anteriormente 
33. Faça outras animações até a linha 89 
34. Na linha 90 dê Keyframe 
35. Salve seu trabalho 
 
CENA 1 – Efeito 
 
1. No layer início 
2. Na linha = 1 > Properties > Action > Is Frame is Load 

Scene : Primeira Parte ( x ) number = 90 
Action > Go to 
Go to Play > Scene : Primeira parte  ( x ) number = 1 ( x ) Go to and Play 

3. Na linha 20 > Properties > Go to 
Go to Play > Scene : Efeito ( x ) number = 1 ( x ) Go to Play 

4. No layer Mensagem 
5. Na linha = 1 > Properties > Label 

Name : Imagem Carregando ( x ) Comemmt 
 
CENA II – Primeira Parte 
 
36. Na linha =1 > Properties > Action > Stop 
37. Na lina = 2 > Properties > Action > Go To > Scene = Primeira Parte 

Frame : ( x ) number = 60 
38. Na linha = 60 > Properties > Action > Stop 
39. Na linha = 61 > Properties > Action > Play 
40. Na linha = 90 > Properties > Action > Stop 
41. Clique sobre o frame > F5 até a linha do tempo = 20 
42. Clique no 1 frame > Properties > Label : Label = Imagem Carregando 
43. Digite o texto : Imagem Carregando .... 
44. Salve seu arquivo e teste a animação 
 

WEFEITO PORCENTAGEM 



 
1. Veja exemplo anexo :  porcentagem.fla 
2. Clique em 12.0 fps e em background coloque preto e ( x ) Show Grid 
3. Nomeie o layer = retângulo 
4. Desenhe o retângulo em branco sem preencher a cor de fundo 
5. Digite na parte de cima 10% e 100 % 
6. Digite na parte de baixo : Imagem Carregando ... 
7. Insira um keyframe na linha do tempo = 10  
8. Insira um layer abaixo e nomeie  de preenchimento 
9. Desenhe em vermelho um pequeno quadrado que corresponda 10% do preenchimento 
10.  Pinte o pequeno quadrado em vermelho 
11. Insira keyframe na linha 2 
12. Selecione a quadradinho em verde > Crtl + C 
13. Crtl + D e arraste a copia para ficar ao lado o 1º quadrado 
14. Insira outros keyframe  conforme mencionado acima até preencher os 100% do  

retângulo 
15. Fazendo todos keyframe até a linha 10 
16. Selecione a linha 1 até 10 > Properties > Tweening 
17. Desative o Grid 
18. Salve e teste > Crtl + Enter 
 
2ª Parte 
 
1. Abra o Word e digite textos em 3D 
2. Crtl C 
3. Volte ao Flash  
4. Insert > Scene 
5. Nomeie a 1ª Cena = Barra e a 2ª Cena = Animação 
6. Na linha 1 da Cena Animação > Crtl + D 
7. Na linha 200 > Insert > Blank Key Frame = F7 
8. Selecione da linha 2 até a 199 > F7 
9. Insira Action > Stop na linha 1 e linha 200 
10. Volta a Cena Barra 
11. No layer = Preenchimento 
12. Na linha 1 > Action > Is Frame Loaded > Scene = Animação 

Frame = 20 
Action > Go to > Go and Play > Scena = Barra 
Frame = 1 

13. Nas demais linhas frame : 40 , 60 ...... 200  como Is Frame Loaded 
14. Nas demais linhas frame : 2 , 3 ......... 10 como Go and Play 
 
3ª Parte 
 
1. Crie um novo arquivo 
2. Digite seu email azul 
3. Keyframe na linha 5 > azul mais claro 



4. Keyframe na linha 10 > azul mais claro 
5. Keyframe na linha 15 > verde mais claro 
6. Keyframe na linha 20 > verde mais escuro 
7. Keyframe na linha 25 > verde escuro 
8. Selecione da linha 1 até 25 > Properties > Tweening 
9. Selecione o desenho > F8 > Movie Clip > Name = email 
10. Windows > Library 
11. Volte a Cena 2 do arquivo porcentagem.fla  
12. Insira o movie clip = email 
13. Properties > Action > Get Url > mailto:webmaster@betomarques.com 
 
FRAME IS LOADED VÁRIAS VEZES NA MESMA ANIMAÇÃO 
 
1. Insira keyframe da linha do tempo 1 até 20 frames  
2. Em cada dois keyframe, coloque uma imagem de porcentagem  
3. Ficará assim 

Keyframe 1 e 2 = 10% 
Keyframe 3 e 4 = 20% 
Kyeframe 5 e 6 = 30% e assim sucessivamente 
 

4. Selecione o frame 1 > Properties > Actions 
 IF FRAME IS LOADED ; Frame =  30 
GO TO AND PLAY ; Frame = 3 
END IF 

5. Selecione o frame 2 > Properties > Actions 
GO TO AND PLAY ; Frame=  1 

6. Selecione o frame 3 > Properties > Actions 
IF FRAME IS LOADED ; Frame = 40 
GO TO AND PLAY ; Frame = 5 
END IF 

7. Selecione o frame 4 > Properties > Actions  
GO TO AND PLAY ;  Frame =  3 

8. Selecione o frame 5 > Properties > Actions 
IF FRAME IS LOADED ; Frame = 50 
GO TO AND PLAY ; Frame = 7 
END IF 

9. Selecione o frame 6 > Properties > Actions 
GO TO AND PLAY ; Frame = 5 

10. Selecione o frame 7 > Properties > Actions 
IF FRAME IS LOADED ; Frame = 60 
GO TO AND PLAY ; Frame =  9 
 END IF 

11. Selecione o frame 8 > Properties > Actions 
GO TO AND PLAY ;  Frame = 7 

 
 



OUTRO EXEMPLO 
 
Suponhamos uma animação de 500 frames e quer a animação apareça só depois do frame 
300 carregado . 
 
• Selecione o frame 3 

Properties .> Action = Go and Play 
Scene = Scene 1 
Frame = 5 Wait for frames  297 extra Frames  

 
• Selecione o frame 4 

Properties > Action = Go and Play 
Scene = Scene 1 
Frame = 2 

 
Conclusão : a animação entrará em loop até que o frame 300 tenha sido carregado e à partir 
daí o  frame 5 funcione normalmente 
 
32- ACTION : FSCOMMAND 
 
FS Command é um comando que a “string” pode ser enviada para um interpretador e na 
qual os argumentos são solicitados conforme o comando especificado 
 
PARÂMETROS DO FSCOMMAND : COMANDOS & ARGUMENTOS  
 
Quit    > sem argumentos 
FullScreen  > true/false 
AllowScale  >  true/false 
ShowMenu  >  true/false 
Exec  > path 
 
 
COMANDO PARA QUE A ANIMAÇÃO SAIA NA TELA TODA 
 
1. No primeiro frame defina uma Action > FSCommand 
2. Na Janela Command : Fullscreen 
3. Na janela Argument : True 
 
 
COMANDO PARA QUE A ANIMAÇÃO APAREÇA EXATAMENTE NO 
TAMANHO QUE FOI CRIADA 
 
4. No primeiro frame defina uma Action >FSCommand 
5. Na Janela Command : Allowscale 
6. Na janela Argument : False 
 



 
33- ACTION : LOAD MOVIE  & UNLOAD MOVIE 
 
Load Movie carrega uma animação num determinada URL  
UnLoad Movie  remove a animação em um determinado trecho da animação corrente 
 
Há duas formas tradicionais de se desabilitar uma instância de botão com Load Movie ou 
não : 
 
1. Sobreponha complemente a área Hit da instância do botão indesejado pela área HIT da 

instância de outro botão  
2. Crie uma keyframe na layer em que está a instância do botão indesejável e elimine-a ou 

substitua-a por um gráfico (na keyframe criada). Pode colocar este gráfico na 5a. frame 
do botão e no keyframe desejado, mude o comportamento da instância do botão por 
gráfico 

 
Observações : 
 
1. O load movie permite que você carregue um outro movie (.swf) por cima do seu movie 

já no browser .  
2. O movie clip e como um movie que já fica em looping (padrão) que pode usar para 

fazer animações  
3. O item Template só está disponível quando o Flash Generator estiver instalado no seu 

computador. O template originalmente é para a utilização do Flash 3 com o Flash 
Generator, que manipula bancos de dados no ambiente servidor e gera um arquivo Flash 
a partir de um template. Mas a Macromedia gerou uma versão diferente para trabalhar 
com isto, uma espécie de kit com o Flash 3 e um componente adicional somente para 
gerar os templates. No Flash 3 apenas, sem utilidade alguma. 

4. Quanto se usa ação como Load Movie, precisa informar o nome do arquivo .swf e o 
Level ( nível ) em que deseja carregar.  

5. Quando usa Unload Movie, basta especificar o Level ( nível ) em que se encontra. 
6. Quando carrega uma animação no mesmo nível em que já outra animação, este será 

substituído pelo nova. 
7. Para descarregar todas as animações, exceto uma , pode usar uma única instância de 

botão ( ou ação de frame ) e com um único "On release" declarar vários "Unload 
Movies" ( especificando só os níveis ). 

 
Como abrir um arquivo SWF dentro de outro 
 
Para abrir um swf dentro de outro, adicionando uma ação, por exemplo, a um botão, através 
do Load Movie. Os argumentos são: 
 
- URL: nome do arquivo flash que deseja carregar exemplo : beto.swf  
- Level #: a animação principal tem o level =0. , caso nomeie outra animação com level=1, 
por exemplo, ele será exibido em cima da animação principal e assim por diante.  
 
 



34 - EFEITO EM 3D NO FLASH 
 
1. Faça um objeto no 3D Max 
2. Rotacione o objeto algumas vezes 
3. Configure o programa para salvar cada quadro da animação em um arquivo diferente 

com extensão tiff 
4. Renderize  
5. O numero de arquivos criado será igual ao número de quadros da animação. 
 
3. Abra o Flash 
4. Windows > Library > Create Symbol 
5. Name : digite 3d ; behavior Movie Clip 
6. File > Importe (Ctrl+R) todos os arquivos criados da seguinte maneira 
7. Insira a Imagem 1 no frame da linha do tempo = 1 
8. Selecione a Imagem 1 > Modifty > Trace Bitmap 

Nos itens Color Threshold e  Minimum Area  coloque valores pequenos para que 
imagem fique mais leve 

9. Insira blankframe na linha do tempo = 2 
10. Insira a Imagem 2 no frame da linha do tempo = 2 
11. Selecione a Imagem 2 > Modifty > Trace Bitmap 
12. Insira blankframe na linha do tempo = 3 
13. Insira a Imagem 3 no frame da linha do tempo = 3 
14. Selecione a Imagem 3 > Modifty > Trace Bitmap 
15. Insira blankframe na linha do tempo = 4 
16. Insira a Imagem 2 no frame da linha do tempo = 4 
17. Selecione a Imagem 4 > Modifty > Trace Bitmap 
18. Clique na seta azul ( à direita da Tela ) para fechar a edição do movie clip 
19. Windows > Library > e arraste o símbolo 3d para a área de trabalho 
20. Crtl + Enter e teste sua animação 
 
35 – ACTION : MOUSE EVENTS 
 
Mouse Events são eventos que devem ocorrer e que satisfaçam certas condições tais como : 
 
1. Press - pressionar,  
2. Release - clicar dentro da área botão ( default do Flash ) ;  a ação é exercida quando 

aperta o botão no estágio Down 
3. Release Outside - clicar fora da área do botão 
4. Roll Over - passar por cima do botão ; usado em menus com submenus ( Track as 

Menu )  
5. Roll Out - sair de cima do botão ; acontece quando o cursor sai de cima do estágio Hit 

do botão 
6. Drag Over - clicar em qualquer parte e arrastar para dentro do botão 
7. Drag Out - clicar dentro do botão e arrastar para fora do botão 
 



WBOTÃO BOLA MENU 
 
1. Veja exemplo anexo : bola_menu.fla 
2. Insert > Scene  
3. Clique na pasta Scene 2 > Properties > digite : apresentação 
4. Clique na pasta apresentação > Insert Scene 
5. Clique na Scene 3 > Properties > digite : serviços 
6. Clique na pasta serviços > Insert Scene 
7. Clique na Scene 3 > Properties > digite : cadastro 

 
8. Volta a Cena Apresentação 
9. Digite na área de trabalho Apresentação 
10. Selecione o keyframe na linha do tempo = 1 > Properties > Definition 
11. Label : digite : apresentação 
12. Insira um keyframe na linha do tempo = 20 
13. Selecione a linha do tempo = 20 > Properties > Action > Stop 

 
14. Volta a Cena Serviços 
15. Digite na área de trabalho Serviços 
16. Selecione o keyframe na linha do tempo = 1 > Properties > Definition 
17. Label : digite : serviços 
18. Insira um keyframe na linha do tempo = 20 
19. Selecione a linha do tempo = 20 > Properties > Action > Stop 

 
20. Volta a Cena Cadastro 
21. Digite na área de trabalho Cadastro 
22. Selecione o keyframe na linha do tempo = 1 > Properties > Definition 
23. Label : digite : apresentação 
24. Insira um keyframe na linha do tempo = 20 
25. Selecione a linha do tempo = 20 > Properties > Action > Stop 

 
26. Windows > Library > Create Symbol 
27. Name : Apresentação ; behavior = graphic 
28. Digite : Apresentação em preto , Arial Black , tamanho = 16 
29. Selecione o texto > Crtl K para alinhar 
30. Vertical  Align marque o terceiro botão 
31. Horizontal Align marque o terceiro botão 
32. Match Size marque em ( X ) 
33. Marque ( x ) Align to Page 
34. Windows > Library > Create Symbol 

 
35. Name : Serviços ; behavior = graphic 
36. Alinhe símbolo conforme mencionado acima 

 
37. Windows > Library > Create Symbol 
38. Name : Cadastro ; behavior = graphic 



39. Alinhe símbolo conforme mencionado acima  
 

40. Windows > Library > Create Symbol 
41. Name : bola ; behavior = graphic 
42. Desenhe uma bola e pinte com uma cor degradê 
43. Alinhe símbolo conforme mencionado acima  

 
44. Windows > Library > Create Symbol 
45. Name : seleção ; behavior : button que servirá para marcar o menu a ser clicado 
46. Insira um bank keyframe no  estágio Over 
47. Clique no ícone 12.0 fps e marque ( x ) Grid para exibir as grades 
48. Exibida as grandes desenhe um retângulo iniciando do lado direito na parte de cima do 

sinal ( + ) ; o retângulo deve ocupar 10 grades x 1 e pinte de azul 
49. Insira um keyframe no estágio Hit e pinte o retângulo com um azul mais claro 

 
50. Windows > Library > Create Symbol 
51. Name : botao1 ; behavior : button  
52. Insira um bank keyframe no  estágio Hit 
53. Arraste o símbolo bola para a edição do símbolo botao1 
54. Selecione o botão1 > Crtl K para centralizar 

 
55. Windows > Library > Create Symbol 
56. Name : área; behavior : button que será uma área onde estará todos os símbolos 
57. Insira um blank keyframe no estágio Hit 
58. Desenhe um retângulo que ocupe 20 grades x 10 
59. Pinte de amarelo e retire as bordas 
60. Selecione o retângulo > Crtl K para centralizar 

 
 
 

61. Name : menu ; behavior = movie clip 
62. Arraste o símbolo bola  
63. Selecione o texto > Crtl K para alinhar 
64. Vertical  Align marque o terceiro botão 
65. Horizontal Align marque o terceiro botão 
66. Match Size marque em ( X ) 
67. Marque ( x ) Align to Page 
68. Nomeie o layer de bola 
69. Insira um frame > F5 na linha do tempo = 2 

 
70. Insira um layer abaixo e nomeie de submenu 
71. Insira um blank keyframe na linha do tempo = 2 
72. Arraste os símbolos : Apresentação , Serviços e Cadastro para o lado direito da bola 
73. Insira um layer abaixo e nomeie de preenchimento 
74. Insira blank keyframe na linha do tempo = 2 
75. Arraste o símbolo seleção para cima da Apresentação 
76. Arraste o símbolo seleção para cima de Serviços 



77. Arraste o símbolo seleção para cima da Cadastro  
 

78. Selecione o símbolo seleção que está sobre Apresentação 
79. Properties > Action 
80. On Mouse Events > Release 
81. Tell Target ; no campo target digite : ../ 
82. Go to and Play ; Label digite : apresentação ; ( x ) Go and Play 

 
83. Selecione o símbolo seleção que está sobre Serviços 
84. Properties > Action 
85. On Mouse Events > Release 
86. Tell Target ; no campo target digite : ../ 
87. Go to and Play ; Label digite : serviços ; ( x ) Go and Play 

 
88. Selecione o símbolo seleção que está sobre Cadastro 
89. Properties > Action 
90. On Mouse Events > Release 
91. Tell Target ; no campo target digite : ../ 
92. Go to and Play ; Label digite : cadastro ; ( x ) Go and Play 

 
93. Insira um layer abaixo e nomeie botão1 
94. Insira na linha do tempo = 1, o símbolo botão1 > Properties > Stop 
95. Insira um keyframe na linha do tempo  = 2 
96. Clique no ícone lápis ao lado do layer botão > Hidden Others para esconder os outros 

layers 
97. Clique na linha linha do tempo = 1 
98. Selecione a bola1 > Properties > Action 
99. On Mouse Events > Release 
100. Go to Next Frame 
101. Clique na linha linha do tempo = 2 
102. Selecione a bola1 > Properties > Action 
103. On Mouse Events > Release 
104. Go to and Stop > Frame = 1 

 
105. Insira um layer abaixo e nomeie de fundo 
106. Insira um blank keyframe na linha do tempo = 2 
107. Desenhe um retângulo do tamanho do símbolo de preenchimento 
108. Clique no lápis do lado do layer fundo > Hidden Others para esconder os outros 

layers 
109. Pinte o retângulo com outro tonalidade de azul 
110. Retire as bordas do retângulo 
111. Clique no lápis do lado do layer fundo > Show All para exibir os outros layers 

 
112. Insira um layer abaixo e nomeie de área 
113. Insira um blank keyframe na linha do tempo = 2 
114. Insira o símbolo área para cima da animação 
115. Clique sobre o símbolo área > Properties > Action 



116. On Mouse Events > Roll Over e Drag Over 
117. ( + ) Go to and Stop 

 
118. Voltar para área principal de trabalho > clique na seta azul para terminar a edição de 

símbolos 
119. Nomeie o layer 1 = menu e arraste o símbolo menu para dentro da área de trabalho 
120. Insira um keyframe na linha do tempo = 10  
121. Clique na linha do tempo = 10 > Properties >  Action > Stop 
122. Clique sobre a bola > Properties > Definition > Instance Name = menu 
123. Crtl + Enter e teste sua animação 
 
 
36 - RELATÓRIO DA ANIMAÇÃO 
 
COMO FAZER UM RELATÓRIO SOBRE SUA ANIMAÇÃO 
 
Este artificio serve para você dar uma restaurada na sua animação de modo a diminuir o 
tamanho em k 
 
1. No Flash 
2. Abra o  arquivo teste.swf 
3. File = Export Movie ( x ) Generate Size Report = que vai criar um arquivo, no caso 

teste.txt , para você fazer uma verificação na animação afim de retirar os excessos 
desnecessários 

 
 
 
37 - FLASH EXECUTÁVEL 
 
O executável stand alone do Flash, que no Windows se chama algo como swflash32.exe é 
aquele programa que mostra suas animações localmente fora do browser.  
Na versão 3 do Flash > File >  Create Projector > salva seu arquivo como .exe 
 
Para que a animação apareça na tela toda  Action > FSCommands> Fullscreen > Value true 
 
1. Transforme sua animação fla em swf 
2. Abra o arquivo swf no Stand-alone Flash Player  
3. File > Create Projector 
4. Nomeie o arquivo executável  
 
** O programa Stand-alone Flash Player vem junto com o Flash 3 : diretório chamado 
Players > SwFlsh32.exe 
 
** Como depois de pronto o executável, se teclar "Esc" ele restaura a janela do 
"standalone". 
 



• Por exemplo : um arquivo executável que não tem nada com o Flash 
                             Utilize o FSCommand  e Command = Exec 
                             Na janela de Arguments = programa.exe 
 
COMO CRIAR UM BOTÃO EXIT ( SAIR ) 
 
1. Crie um botão exit chamado SAIR  para sair da apresentação executável 
2. Clique sobre o botão > Action > FSCommand > Command = Quit  
 
COMO CLICAR EM UM BOTÃO PARA FECHAR O EXECUTÁVEL E ABRIR 
OUTRO EXECUTÁVEL 
 
3. Crie um botão 
4. Action > FSCommand > Command > Exec ; Argument > caminho para o aplicativo 

a ser aberto 
Action > FSCommand > Comamand > Quit 

 
38 - PROBLEMAS COM PLUGIN DO FLASH 
 
1. Se seu Browser for Netscape inferior 4.5, ele vai direcionar para a página do plugin, e 

preciso fechar o Netscape e rodar o programa que você baixou  da Macromedia que é o  
shockwave_installer.exe. Depois você abre o Netscape e entre numa página que tenha 
animações em Flash 
 

2. Se seu Browser for Internet Explorer versão inferior a 4.0  caso não abra uma página 
em Flash Clique em exibir -> Opções ; 

• Clique na orelha segurança; 
• Na caixa conteúdo ativo marque todas; 
• Aperte o botão "Nível de segurança"; 
• Selecione a segurança Media; 
• Pronto feche as janelas e confirme tudo. 
• Abra um arquivo em flash para testar 

 
39 -  DICAS E OBSERVAÇÕES FINAIS 
 
TUTORIAL SOBRE BOTÕES 
 
http://www.FlashCentral.com/Tech/Buttons/Toggle.htm
 
http://www.insomniac.com/AAL/tut-fl/index.shtml  
 
http://www.macromedia.com/support/flash/ts/documents/advanced_buttons.htm  
 
http://www.users.bigpond.com/xtian/main.html  
 
http://www.users.bigpond.com/xtian/floatmenu.html  

http://www.flashcentral.com/Tech/Buttons/Toggle.htm
http://www.insomniac.com/AAL/tut-fl/index.shtml
http://www.macromedia.com/support/flash/ts/documents/advanced_buttons.htm
http://www.users.bigpond.com/xtian/main.html
http://www.users.bigpond.com/xtian/floatmenu.html


 
F.A.Q. DO FLASH 
 
http://www.flasher.net/faq  
 
http://www.flasher.net/flashpad.html   
 
SONS 
 
ftp://ftp.htc.dk/pub/WAV  
 
• O termo Shockwave se refere aos plug-ins e controles ActiveX para Director, Flash e 

Authorware, para a Web. 
 
PROGRAMAS PARA DIVIDIR IMAGEM 
 
1 ) Programa freeware chamado PictureDicer  :  http://www.ziplink.net/~shoestring/dicer01.htm
 
2 ) Programa Fireworks da Macromedia  : http://www.macromedia.com/fireworks
 
ASSINATURA DIGITAL 
 
http://www.digimarc.com  -  faz a assinatura digital ( watermark ) para proteger seus 
trabalhos e eles oferecem também serviços gratuitos 
 
Exemplo :  http://www.blueorange.com.br/sig/sig.html  
 
TUTORIAL SOBRE FLASH 
 
http://www.flasher.net/zine/3  
 
http://freeflight.cockpit.be/bertoflash
 
COMO INCLUIR TEXTO A PARTIR DO WORD 
 
Para incluir os arquivos em doc como bitmap 
 
1. Abra o documento no Word 
2. Pressione a tecla < Print Screen > do teclado (ela fica em cima da tecla < Insert > 
3. O conteúdo da tela é transformado num bitmap, e copiado para a área de transferência 
4. Abra o Flash, e aperte < Crtl + V > 
 
Importando os arquivos em doc  
 
1. Abra o Flash 
2. File > Import 
3. Especificar no tipo de arquivos "all formats" 

http://www.flasher.net/faq
http://www.flasher.net/flashpad.html
ftp://ftp.htc.dk/pub/WAV
http://www.ziplink.net/%7Eshoestring/dicer01.htm
http://www.macromedia.com/fireworks
http://www.digimarc.com/
http://www.blueorange.com.br/sig/sig.html
http://www.flasher.net/zine/3
http://freeflight.cockpit.be/bertoflash


4. Localize a arquivo e o importe 
5. Aparecerá uma mensagem avisando que este formato de arquivo não é compatível 
Confirme e o arquivo será introduzido no Flash 
 
Usando uma janela de texto do Word 
 
1. Coloque o texto desejado em uma janela de texto do Word.  
2. Selecionar a janela como um todo e copiar no Flash  com Ctrl C  e Ctrl V 
 
COMO TRAZER IMAGEM PARA FRENTE 
 
Se os elementos estiverem no mesmo layer é só selecionar : 
 

• Para ir para frente e ativar:  
Modify > Arrange > Bring To Front  ou Control+Shift+Up  

• Para ir para baixo : 
Modify > Arrange > Send To Back ou Control+Shift+Down 

 
Se estiverem em layers diferentes é só arrastar o layer para cima ou para baixo do layer do 
outro objeto 
 
EFEITO VIBRAR OBJETO 
 
1. Veja exemplo anexo : vibrar.fla 
2. Windows > Library > Create Symbol 
3. Name : texto ; behavior = graphic 
4. Digite um texto > Crtl K para centralizar 
5. Windows > Library > Create Symbol 
6. Name : vibrar ; behavior = movie clip 
7. Arraste o símbolo texto para edição do movie clip 
8. Crtl K para centralizar 
9. Nomeie o layer de cima 
10. Selecione a linha do tempo = 1 > Edit > Copy Frames 
11. Insira um layer abaixo e nomeie de meio 
12. Selecione a linha do tempo = 1 > Edit > Paste Frames 
13. Insira um layer abaixo e nomeie de abaixo 

 
14. Selecione layer cima e dê um keyframe na linha do tempo = 20 
15. Clique no lápis ao lado layer cima > Hidden Others para esconder os outros layers 
16. Selecione a linha do tempo = 20  e movimente o texto para o alto e para direita 
17. Selecione a linha do tempo 1 até 19 > Properties > Motion > Tweening 

 
18. Selecione layer meio e dê um keyframe na linha do tempo = 20 
19. Neste layer não há Tweening Motion 

 
20. Selecione layer abaixo e dê um keyframe na linha do tempo = 20 
21. Clique no lápis ao lado layer abaixo > Hidden Others para esconder os outros layers 



22. Selecione a linha do tempo = 20  e movimente o texto para baixoe para esquerda 
23. Selecione a linha do tempo 1 até 19 > Properties > Motion > Tweening  
24. Clique no lápis ao lado layer abaixo > Show All para exibirr os outros layers 
25. Clique na seta azul para terminar a edição do símbolo : vibrar 
26. Arraste o símbolo vibrar para área de trabalho 
27. Crtl + Enter e teste sua animação 
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